LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-24-2013, 09:38 AM   #1
mwlaursen@aol.com
LQ Newbie
 
Registered: Jun 2008
Posts: 12
Blog Entries: 1

Rep: Reputation: 0
Cool Setting up Redhat 6.0 with a static ip address.


I am having trouble setting up the IP address on my new server. I go to system>network connections. I add a new connection, I then go to the IPv4. Change method to manual. Setup my address, and Netmask to the same as another machine I have. The address is different than the other machine. and set the gateway to the same as the other machine. The results is I cannot use firefox, but I can ping my other machine from the new box. I not sure why firefox will not work?
 
Old 03-24-2013, 10:22 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
please show us the output of ifconfig -a and route -n
 
Old 03-24-2013, 01:28 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,802

Rep: Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704
Quote:
Redhat 6.0
that would be " RHEL 6.0 " and not the current Redhat Enterprise Linux 6
RHEL 6.4

and NOT the very old RH6.0 from 1999


did you set up the ipv4 to receive ip address ONLY
or is it also using your ISP's DNS

I normally disallow the isp's dns and use google ( 8.8.8.8 and 8.8.4.4 )
 
Old 03-24-2013, 06:44 PM   #4
mwlaursen@aol.com
LQ Newbie
 
Registered: Jun 2008
Posts: 12
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Chris here is your answer.

ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:16:35:3A:AE:89
inet addr:172.168.1.8 Bcast:172.168.255.255 Mask:255.255.0.0
inet6 addr: fe80::216:35ff:fe3a:ae89/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5843 errors:0 dropped:0 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:841894 (822.1 KiB) TX bytes:6211 (6.0 KiB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 b) TX bytes:480 (480.0 b)

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
172.168.0.0 0.0.0.0 255.255.0.0 U 1 0 0 eth0
0.0.0.0 172.168.1.20 0.0.0.0 UG 0 0 0 eth0

John VV

I have Red Hat Enterprise Linux Server
Release 6.0 (Santiago)

Thanks for your replys!!

Mark
 
Old 03-25-2013, 03:21 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
OK,

so that IS the correct gateway? Is that really a /16 subnet? 255.255.0.0?? Ewww.

can you ping a website name? Does it resolve the name to an IP address? should you be using a proxy instaead of connecting directly?
 
Old 03-25-2013, 05:50 PM   #6
mwlaursen@aol.com
LQ Newbie
 
Registered: Jun 2008
Posts: 12
Blog Entries: 1

Original Poster
Rep: Reputation: 0
The 172.168.1.20 is my router that is connected to the modem. Yes, I use a submask of 255.255.0.0.

My other machine that has a static ip address does not use a proxy, but I can try that.

Thanks!!
 
Old 03-25-2013, 06:09 PM   #7
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Quote:
Originally Posted by mwlaursen@aol.com View Post
The 172.168.1.20 is my router that is connected to the modem. Yes, I use a submask of 255.255.0.0.

My other machine that has a static ip address does not use a proxy, but I can try that.

Thanks!!
What do you mean 172.168.1.20 is your router? This is an routable IP address that belongs to AOL. Is your server behind NAT?
 
Old 03-25-2013, 07:24 PM   #8
mwlaursen@aol.com
LQ Newbie
 
Registered: Jun 2008
Posts: 12
Blog Entries: 1

Original Poster
Rep: Reputation: 0
The router that is connected to the DSL modem. I have several machines connected to it.
 
Old 03-27-2013, 11:50 PM   #9
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,261

Rep: Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028Reputation: 2028
If this is an internal LAN (as it sounds) you should only use IPs in the approved private ranges https://en.wikipedia.org/wiki/Private_network.
As above, 172.168.x.x would be an external address range already owned by someone else.
 
Old 06-02-2013, 02:34 PM   #10
mwlaursen@aol.com
LQ Newbie
 
Registered: Jun 2008
Posts: 12
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Sorry I have been offline for surgery.

I have worked on my system today, and found that the IP address did not matter, but I now set to the standard. I found a switch in Red Hat 6 that needed to be set to server and not desktop in the firewall. I am now up and running.

Thanks for all the help!!

Mark
 
  


Reply

Tags
networking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to setting a static ip address on slackware64 13 wubai Slackware 5 11-12-2012 07:21 PM
setting static IP on linux PCs with no static IP address from internet provider? solvetek Linux - Networking 1 10-22-2011 08:04 AM
[SOLVED] Setting a dns-server on a static ip address. jdkaye Debian 3 06-24-2011 10:58 PM
Setting a static IP address thedp Slackware 4 05-02-2008 01:09 PM
Setting up a static I.P. address partyk1d24 Linux - Networking 13 12-29-2005 06:23 AM


All times are GMT -5. The time now is 11:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration