LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-13-2004, 11:07 PM   #1
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,085

Rep: Reputation: 46
sendmail won't send locally!


I finally managed to get sendmail working externally so I can configure all my pop3 accounts in my mail client to use it, and it works but locally (serverwise) it does not work. If I try to send mail through the command line I get this:

The original message was received at Tue, 13 Apr 2004 22:57:11 -0400
from localhost.localdomain [127.0.0.1]

----- The following addresses had permanent fatal errors -----
<validemail@host.com>
(reason: 550-Verification failed for <root@localhost.localdomain>)

----- Transcript of session follows -----
... while talking to iceteks.com.:
>>> DATA
<<< 550-Verification failed for <root@localhost.localdomain>
<<< 550-unrouteable mail domain "localhost.localdomain"
<<< 550 Sender verify failed
550 5.1.1 <validemail@host.com>... User unknown
<<< 503 valid RCPT command must precede DATA



How can I get it to work? I want to be able to use the php mail() function so I can make myself a php based newsletter management system.


Ok, I think I know what I need to do. I need to make it so sendmail does not make mail come from root@localhost.localdomain but rather from a valid email address, since the emails DO make it out of the server in the sense that the smtp server connects to the host I'm trying to send, but the host rejects localhost.localdomain as a from email, which makes sense. So any ways to make it default to something like my real email address or something?

Last edited by Red Squirrel; 04-13-2004 at 11:46 PM.
 
Old 04-14-2004, 12:01 AM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
you could try aliasing your machine by putting an entry in /etc/hosts

like

your IP blahname.blahdomain.net blahname

your IP should be the machines IP not 127.0.0.1 .
you will have to restart before the machine accepts the new name.
 
Old 04-14-2004, 12:07 AM   #3
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,085

Original Poster
Rep: Reputation: 46
Is there a way I can just alias the email nobody@localhost.localdomain and not the entire domain? I think some applications rely on localhost.localdomain as being the loopback, so it would cause problems if I aliased it. Thanks for the help anyway, though.
 
Old 04-14-2004, 12:29 AM   #4
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
the 127.0.0.1 is an alias already to localhost.localdomain

if you veiw your /etc/hosts file you will see what Im talking about.

I have done this aliasing of my IP with a hostname and nothing refuses to work.

localhosts.localdomain is still 127.0.0.1 is still loopback regardless.
127.0.0.1 localhost localhost.localdomain
68.124.99.123 yourcomputer yourcomputer.yourdomain.net

I never said change the 127.0.0.1 line did I?

Last edited by AutOPSY; 04-14-2004 at 12:30 AM.
 
Old 04-14-2004, 08:45 AM   #5
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,085

Original Poster
Rep: Reputation: 46
sorry I miss read your post, I th ought you wanted me to alias localhost.localdomain to something other then root.

But if I make my own host, what will that do? the email will still be sent as root@localhost.localdomain, and that's what I need to change. What I need to do is make it come from a valid email by default if the from: field is not sent.
 
Old 04-14-2004, 05:45 PM   #6
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,085

Original Poster
Rep: Reputation: 46
Been trying everything, no luck. Someone was telling me I need to run a DNS server to run an email server, is this the case? Thing is though, it's only locally that it does not work. I can send email to root@borg from my mail client and it get's there. Obviously this only works on my network but that's all I need. What's more important is being able to send outside, which I can do fine, but not on the server through php or even using sendmail in the console.

Edit: If I type in the cli
sendmail -f valid@email.com
(message)
.


It works, so all I need is to make sure the email comes from a valid host, and I'm set. So how would I manage to make php mail() do that? I can't seem to get it working that way, I checked in php.ini and there's a section for the from but it says win32 only, for linux it only has an option for sendmail path, which I put and is correct.

Thanks in advance!

Last edited by Red Squirrel; 04-14-2004 at 06:51 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble getting mail to send locally zardozcs Linux - Software 5 02-04-2004 02:01 PM
sendmail - works locally but not from outside ereeno Linux - Software 5 02-03-2004 01:40 AM
how do I send and recieve mails locally? hpnadig Linux - Networking 10 01-04-2004 06:23 AM
Sendmail - Bounced messages returned to SmartHost Postmaster not locally... Vince0000 Linux - General 0 12-02-2003 02:54 PM
Sendmail: Deliver locally and remote mague Linux - Software 1 11-04-2003 07:08 PM


All times are GMT -5. The time now is 04:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration