LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-14-2002, 11:17 AM   #1
oth88
LQ Newbie
 
Registered: Jun 2002
Location: China
Distribution: Mandrake 8.2
Posts: 8

Rep: Reputation: 0
ScriptAlias - cgi-bin


Hi,

I have got mysql working, DBI and Perl but when I try to config apache to accept the ScriptAlias I get the following message when I try to restart apache:

Executing: /etc/rc5.d/S85httpd start
> Starting httpd: Syntax error on line 4 of /etc/httpd/conf/httpd.conf:
> Invalid command 'ScriptAlias', perhaps mis-spelled or defined by a module not included in the server configuration
> [FAILED]

I fill in the ScriptAlias box as </cgi-bin/ /var/www/cgi-bin/>. The "May execute CGI" box is crossed. I've set all the files and directories to nobody/nogroup.

Any help would be appreciated.

David
 
Old 09-15-2002, 08:40 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,532

Rep: Reputation: 132Reputation: 132
i guess u have to enclose the directory in ""
"/var/www/cgi-bin/"
that's the way in my config and it works
if this is not the solution post your entire <ScriptAlias-tag>
good luck
jens
 
Old 09-16-2002, 09:04 AM   #3
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,532

Rep: Reputation: 132Reputation: 132
...a couple lines below the ScriptAlias there u have to define the same directory once more but without a / at the end
have u done that?
 
Old 09-16-2002, 10:58 AM   #4
oth88
LQ Newbie
 
Registered: Jun 2002
Location: China
Distribution: Mandrake 8.2
Posts: 8

Original Poster
Rep: Reputation: 0
Hi j-ray,

Thanks for your input. I just got it working by using Webmin.
I went to Servers > Apache Webserver > Virtual servers > default server > Per-directory options > Directory /var/www/cgi-bin > Access control >
There I set "Allow all requests" and it worked!!!

Now I have to find out what has really happened. One book told me that it was all a matter of directory permissions. I tried everything I could think of but it wouldnt work. My error log was telling me "client denied by server configuration".

I have been trying to setup with linuxconf and I cannot see any changes after my new settings with webmin. I've had trouble before with linuxconf putting the conf files in a different directory. Maybe this has happened this time.

Anyway, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cgi-bin Cool_Hand_Luke Linux - Newbie 3 04-02-2005 04:32 PM
CGI to work out side of cgi-bin? crashedspine Linux - Newbie 13 09-02-2004 09:49 PM
Cgi-bin Llwyd Linux - Networking 3 03-01-2003 02:46 PM
http://www.burstnet.com/cgi-bin/ads/ad7954a.cgi/3980/RETURN-CODE rverlander LQ Suggestions & Feedback 1 06-07-2002 08:35 AM
cgi-bin is hosed.... Citizen Bleys Programming 2 01-22-2002 08:33 AM


All times are GMT -5. The time now is 01:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration