LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-19-2004, 12:43 PM   #1
RMSe17
Member
 
Registered: Jul 2004
Posts: 31

Rep: Reputation: 15
Screen Problem after KDE shutdown


Hi, I am running Kanotix 6-2004 (2.6.6 Modified Kernel) on a Dell Inspiron 8600, with nVidia 5200Go card, my screen was autodetected at a lower resolution that is in windows, but I didn't mess with it yet, so anyway, everything works, including KDE, but when I shut down, and exit KDE, the screen gets all screwed up, instead of text, there are tons of dots and dashes scrolling on screen, as the system shuts down. What is my problem?

Note: When using Knoppix 3.4 (base for Kanotix) the same problem happened, with both the 2.4.x and 2.6.6 kernels, identical behavior.

Last edited by RMSe17; 07-19-2004 at 12:44 PM.
 
Old 07-19-2004, 04:51 PM   #2
csanchisb
LQ Newbie
 
Registered: Jun 2004
Distribution: Opensuse 11
Posts: 22

Rep: Reputation: 15
The same on a Pentium IV with Mandrake 9.2 and 10.0 for me. it has to do with the nvidia driver (I know because I installed it myself and THEN it started to happen).
 
Old 07-19-2004, 07:28 PM   #3
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
You need to download the Kernel source of your distro and the Nvidia driver (NVIDIA-Linux-x86-1..0-6106-pkg1.run)

Get into a console -- DON'T start X automatically -

Rmmod nvidia in case a "screwed" copy of the NVIDIA module exists.

then follow the instructions on the Nvidia site how to install. (Print before logging off if you only have 1 machine and can't stay on the internet while fixing your other box).

You can tell if it's working properly as you'll see the NVIDIA splash screen before X starts.

If your Kernel is wrong you'll probably get a weird resolution of something like 500 X 320 which looks HORRIBLE so follow the instructions to the letter.

If you update your kernel REBOOT before applying the NVIDIA fix.

In anycase ensure any source patches have been applied to the kernel BEFORE applying the NVIDIA fix.

Last edited by 1kyle; 07-19-2004 at 07:37 PM.
 
Old 07-20-2004, 11:19 AM   #4
csanchisb
LQ Newbie
 
Registered: Jun 2004
Distribution: Opensuse 11
Posts: 22

Rep: Reputation: 15
No, I did install the driver properly and it works OK. It does show the splash screen, actually, but I can't use the text terminals anymore after I start X with the nvidia driver. That is the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown problem after upgrading to KDE 3.4 Pheidon Suse/Novell 11 05-21-2005 02:46 AM
KDE shutdown problem mebrelith Fedora 13 02-25-2005 11:32 PM
Shutdown problem Suse 9.0 Prof KDE finnhs Linux - Distributions 1 02-15-2004 03:09 PM
KDE 3.0 Screen Resolution problem dai Linux - General 4 09-05-2002 03:09 AM
KDE Shutdown/Restart Screen Hangs maplink Linux - Software 1 03-04-2002 11:06 AM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration