LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-17-2003, 11:14 AM   #1
oneiltj
LQ Newbie
 
Registered: Jan 2003
Location: NE, Ohio
Posts: 19

Rep: Reputation: 0
Unhappy Samba blew my passwd?


Life was good until I attempted to make my Samba machine a domain controller. Now I can't login to the linux side ( console) with any accounts. It's like my passwd db was nuked.

I logged in using grub to single user mode and did a passwd on root and another account to no avail. what did I do to my self? I think the message was unknown password.

Anyone have any suggestions?

Thanks in advance.

signed
wrappingupbulletholesinfoot :-(
 
Old 01-17-2003, 11:48 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,005
Blog Entries: 54

Rep: Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763Reputation: 2763
What's in the logs?
 
Old 01-18-2003, 12:47 PM   #3
oneiltj
LQ Newbie
 
Registered: Jan 2003
Location: NE, Ohio
Posts: 19

Original Poster
Rep: Reputation: 0
I didn't have the presence of mind to look there. ( feeling pretty dog gone foolish ) I was in a bit of a panic. It seems that 10 minutes before I made the change that sent me up the river I called my customer and told him I would deliver the box in the afternoon. ouch

I fixed it. The hard way. I happened across a friend last night that had some interesting insight:

When I enabled Samba as a domain controller that PAM begain pointing to the smbuser file for authentication. hoseing PAM. To fix it i went to single user mode disabled pam and samba authentication, reset SU and my account. I could again login.

The default os level was 22. I changed this to 60. I'm sure this did not help. Samba again ran.

Now if I didn't hurt myself I found after I delivered the machine samba quit working and that I could not see it on the customers netowrk at all. :-( In desperation to clean any remain self inflicted bad I even un installed the samba RPMs and reinstalled. -- Better still no good. Samab smbpasswd whined about a lack of an existing passwd file in /etc. NUTS!!

A reformate and reload of rehat 8. finaly!!! fixed the problem. I have a happy(er) customer.

I have to change the dressing on my foot now. :-)
t
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba syncing with /etc/passwd and /etc/shadow iceman47 Linux - Software 7 01-23-2008 08:31 AM
Samba asking for passwd - Winxp Pro apara197 Linux - Networking 2 11-06-2005 07:48 PM
unencrypted passwd samba-client 3.0.4 JimBass Linux - Networking 3 07-06-2004 11:10 AM
Samba guests and changes in /etc/passwd krajzega Linux - Networking 1 03-08-2004 07:53 AM
How to authenticate SAMBA against /etc/shadow or passwd ?? freunda Linux - General 3 03-12-2002 04:34 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration