LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-19-2004, 08:19 PM   #1
haoscar
LQ Newbie
 
Registered: Jul 2004
Posts: 24

Rep: Reputation: 15
rsh : connection refused problem on RH9


Hi ,
I installed MPICH on my RH9 box. MPICH uses rsh for communicating with localhost. It has occured to me that rsh is refusing conections.

I searched on the net and found that I need to make a .rhosts file in every user directory and it should have the hostname & username to use for rsh.

Even a command like rsh localhost /bin/ls is returning connection refused.

I saw a previous post on this forum which said that there was need to make a rsh file for xinetd to start it. I dont have that file looks like.

How do I go about creating it. & making rsh work??.Please help,

Best regards
haoscar
 
Old 07-19-2004, 09:18 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
You have to see if the rshd server is installed. Normally this daemon receives the name "/usr/sbin/in.rshd". If you don't have it all you need is to install the rhsd package of your distribution. After install the package you will have "/etc/xinetd.d/rsh" which you must inspect/edit because there is a line "disable = yes" in this file. If this line is as I wrote it, you must edit it to "disable = no". After save this file, you must restart xinetd: "service xinetd restart". You don't have to put a .rhosts file in each user. You have just edit /etc/hosts.equiv to contain a list of trusted hosts and also a .rhosts in the /root directory which is the home for root. You have also put a line with "rsh" in /etc/securetty.

I hope this helps.
 
Old 07-19-2004, 10:53 PM   #3
haoscar
LQ Newbie
 
Registered: Jul 2004
Posts: 24

Original Poster
Rep: Reputation: 15
Smile

wont putting .rhosts file in root directory give access to run absolutely any command remotely.Isnt this dangerous. Or it not a thing to worryy??
Thanks for your reply,
haoscar
 
Old 07-19-2004, 11:12 PM   #4
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Any command really could be run but just from the machines you specify in /etc/hosts.equiv and /root/.rhosts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection refused rsh onaeem Linux - Networking 7 02-25-2011 12:44 AM
RH9 Sendmail: connection refused DaddyBad Linux - Newbie 9 08-30-2010 08:35 PM
rsh localhost - connection refused mstembri Linux - General 11 10-22-2007 09:30 AM
rsh localhost : connection refused StressedLemming Linux - Networking 1 11-09-2003 12:20 PM
RH9 apache connection refused from external IP addr ashv3524 Linux - Newbie 5 11-08-2003 09:41 AM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration