LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-22-2003, 07:25 PM   #1
arunkk
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Rep: Reputation: 0
Red Hat 8.0 SMP / Poweroff Problems


Hi, I just installed RH 8.0, on a dual processor machine, and also on a single processor machine... When it boots up on the dual processor, I select the RH 8.0 SMP to run, and on the other machine, I just select the default(NOT smp).

When I do a 'poweroff' command on the dual processor, it says "shutting down all devices" and finally "powerdown", but the system just sits there, it doesn't go off..

When I do the same 'poweroff" on the single processor machine, it goes down completely, which is what I need.

I am new to Linux so if anyone can help me out, I would greatly appericiate it. Thanks,
 
Old 08-22-2003, 07:42 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Try loading the following module as root:

modprobe apm

then use the shutdown command:

shutdown -h now

If it works, add the modprobe apm line to your /etc/rc.d/rc.modules or /etc/rc.d/rc.local if you don't have /etc/rc.d/rd.modules
 
Old 08-23-2003, 02:56 AM   #3
zebbedi
LQ Newbie
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 18

Rep: Reputation: 0
To make it work on the dual processer machine, assuming your using grub under redhat 8 edit the file /etc/grub.conf and add "apm=power_off" to the end of the SMP kernel line

eg:

kernel /boot/vmlinuz-2.4.19-smp ro root=/dev/hda2 hdd=ide-scsi apm=power_off
 
Old 08-26-2003, 12:57 PM   #4
arunkk
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
First, I tried loading the module as root:
modprobe apm
I get an error saying that cannot locate module

Second, I edited the file /etc/grub.conf to add the line:
apm=power_off to the end of the file, and that didn't seem to work either,

Any other suggestions?

Thanks
 
Old 08-27-2003, 03:31 AM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
How did you become root? "su"? Try using "su -" , then try again modprobe apm and see if it helps
 
Old 08-27-2003, 09:40 AM   #6
arunkk
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
I login as root, then I tried the modprobe apm...I also typed in su to become superuser, and tried the same modprobe, still no luck.....Any help?


If I can't load the module, any way I can enable poweroff (apm) with smp mode?

Thanks,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat does not plan to release another product in the red hat linux line... Whitehat General 5 11-03-2003 07:33 PM
Red Hat 8.0 SMP / Poweroff Problems arunkk Linux - Software 2 08-26-2003 07:09 PM
Red Hat 9.0 Problems ivan_bdg Linux - Software 1 07-14-2003 08:43 AM
Red Hat Problems.. ^|Drunk|^ Linux - General 3 06-26-2003 08:20 PM
problems with red hat 9 delux Linux - Newbie 3 06-21-2003 01:38 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration