LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-11-2003, 09:29 PM   #1
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Rep: Reputation: 31
Re booting Mandrake 9.1


Hi
Have discovered on starting up Mandrake 9.1 that it stops at line Doing alsactl to restore mixer settings
Have left this message on screen for some time but nothing further happens
Reset reboot from CD and have gone though three or four complete reinstall upgrades from CD. End result the same NO KDE boot up to desktop.
Any suggestions as to how I can get linux to reboot
System has been working fine and have address book ,emails and favorites websites all configured in active Mandrake 9.1
Maurice
 
Old 11-12-2003, 09:29 AM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
You need to turn off alsa or alsasound untill you can fix it. To turn it off boot using linux single at the lilo boot prompt.

Then try this:
/sbin/chkconfig --list
Look for alsasound or maybe just alsa and do this:
/sbin/chkconfig --level 12345 alsasound off
or
/sbin/chkconfig --level 12345 alsa off

Then /sbin/init 3 or 5 should let you complete the bootup.
 
Old 11-12-2003, 06:31 PM   #3
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Original Poster
Rep: Reputation: 31
Turn off alsa

Thanks /bin/bash
for information. One problem .How can I turn off ALSA when I am unable to proceed further in Mandrake 9.1 upgrade.
I will try the single command when the system halts at the line.
Doing asctl to restore mixer settings
Maurice
 
Old 11-12-2003, 06:56 PM   #4
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
At the lilo prompt, or if you get a lilo menu just hit <Esc> to get the lilo prompt, type linux single. That should boot you into a single user shell. From there you can disable alsa using the /sbin/chkconfig command.

If you can't get to a prompt using linux single then try booting Mandrake CD#1 and at prompt hit <F1> then type rescue. After booting into rescue tell it to mount your partitions under /mnt then go to console and type chroot /mnt and the chkconfig commands.

Last edited by /bin/bash; 11-12-2003 at 06:57 PM.
 
Old 11-12-2003, 07:06 PM   #5
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Original Poster
Rep: Reputation: 31
Delete ALSA

Still unable to pass bootup line.Doing alscl to restore mixer settings
Can press retart button and boot to Windows
Grub is my normal menue program.
Am waiting for Mandarke 9.2 Cds to arrive to install upgrade and see if the linux system will reboot.
Unable to reach a terminel to command level.
My sound card is on motherboard and is located in Summary.
Your card currently use the ALSA "snd-via 82xx drivers
default driver for your card sndvi8 82xx
The above information may be of some use to solve my bootup install problem
Maurice
 
Old 11-12-2003, 07:39 PM   #6
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Original Poster
Rep: Reputation: 31
Delet ALsa

Hi /bin/bash
Booted Mandrtake Cd#1 Rescure ,mount pattitions under/mnt go to console
type in chroot/mnt Bash: No such file or directory. type chconfig : Command not found.
Type fackshutdown and system shuts down.
Thanks for information regarding Rescue ,There is hope yet of a bootup to KDE desktop. Await further instructions
Maurice
 
Old 11-12-2003, 07:56 PM   #7
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
That should be:
chroot /mnt
and
/sbin/chkconfig --level 12345 alsa off
exit
 
Old 11-13-2003, 12:58 AM   #8
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Original Poster
Rep: Reputation: 31
Mandrake bootup

Hi Bin/Bash
Good news making progress with KDE.
Used I to enter interactive startup.
By removing ALSA the system does reboot.
No sound ,Volume control.
Modules .conf has errors and found my USB printer stopt working
Can use email now in KDE.
Now I need Sound and Printer to work once again
Maurice
 
Old 11-13-2003, 01:45 AM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
Glad to hear that it is booting. When you say modules.conf has errors errors is this related to alsa.

What type of sound card do you have?
What are the /etc/modules.conf lines for the sound card?
If you type lsmod |grep snd does it show your module as loaded
If your sound modules are loaded try running alsamixer and setting the sound levels for master and PCM.

Try running alsactl --debug store and see if you get any info.

Note if it locks up at this state you should be able to switch to another login terminal by pressing <Ctrl>+<Alt>+<F2> then killall -9 alsactl should kill the process or run ps and then kill <PID> where pid is the processID of alsactl.
 
Old 11-13-2003, 06:32 PM   #10
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 337

Original Poster
Rep: Reputation: 31
Mandrake bootup

Hi /bin/bash
probeall scsi_hostadapter ide-scsi
probeall usb-interface usb-uhci
above snd-via82xx snd-pcm-oss
alias sound-slot-0 snd-via82x
This my /etc/modules.conf after I had deleted a line of code printed above .conf
Where that line of code came from I do not Know but that was preventing the linux system bootup. Easy when you know how.
My Onboard Audio is VT8363
Volume Icon has tobe unmuted and Aumix set sound levels so do have audio playing plus my Printer is also working.
Aumix File save does not seem to save and I note that Mute all is always tickt.
Thank you for all your help much appreciated
Maurice
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual booting fedora core 2 and mandrake: can't boot mandrake any more mgyamada Fedora 1 10-04-2004 07:39 AM
Mandrake 10 CD not booting? xanas3712 Linux - Newbie 5 04-29-2004 02:52 PM
Mandrake 10.0 CD not booting Riley Mandriva 6 03-15-2004 09:27 PM
Booting Mandrake 9.2 RND Mandriva 0 02-16-2004 09:56 PM
Mandrake not booting from CD HoosTrax Linux - Newbie 4 02-04-2004 05:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration