LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-31-2006, 08:16 PM   #1
tisource
Member
 
Registered: Feb 2002
Posts: 322

Rep: Reputation: 30
QEMU networking bridge not working


I've got QEMU 0.8 (i386 binaries provides from QEMU homepage), and I need to be able to browse the local subnet with it (XP Professional is my guest/emulated OS), but I can't seem to get it working.

I can do user-net, and get onto the Internet, but that doesn't give me access to the local subnet.

I did 'modprobe tun' and then granted everyone read and write permissions to /dev/net/tun.

However, when I fire up QEMU (using the -net nic,tap params), it says tun0 does not exist. I'm a bit lost!

I have read many howto's, and they are very cryptic to me. One suggests installing openvpn and configuring some stuff... I'm unsure as how to proceed.

My plans are to bridge the tun0 interface with eth0.

What do I need to do?
 
Old 02-01-2006, 01:29 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Most people use vmware to run two OSes simultaneously on one machine. You might want to look into that. There are certainly more people who would be familiar with vmware than with qemu.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qemu--getting Samba networking going dgermann Linux - Networking 2 01-08-2006 02:47 PM
Qemu on Debian not working? alpha_foobar Linux - Software 4 05-16-2005 03:11 AM
qemu: qemu stopped right after command exec bitpicker Linux - Software 1 03-04-2005 11:25 PM
slackware networking through XP bridge zigmund555 Linux - Networking 5 01-31-2004 10:43 AM
Networking not Working aeb105 Linux - Newbie 5 11-07-2003 11:12 AM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration