LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-05-2003, 10:00 AM   #1
a_morgan
LQ Newbie
 
Registered: Nov 2002
Location: BC, Canada
Distribution: Red Hat 9
Posts: 12

Rep: Reputation: 0
problems installing bluefish (gtk-config errors)


I want to install bluefish but I get errors on the ./configure:

--------------------------------------------------------------
...
checking for catalogs to be installed... de da fr ru ro cs es el en ja it sv pt_BR hu pl nl
./configure: line 1: gtk-config: command not found
./configure: line 1: gtk-config: command not found
checking for gtk-config... no
checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking "for GTK - microversion \>= 7"... ./configure: line 1: no: command not found
./configure: line 5044: test: -gt: unary operator expected
no
configure: error: GTK was not detected
./configure: line 5063: exit: or: numeric argument required
./configure: line 5063: exit: or: numeric argument required
---------------------------------------------------------------

I got the gtk2.2.2 pkg from RedHat and tried a -U -> it said already installed.

I did a locate for gtk-confi -> nothing.

I did a rpm -ql on the package -> no gtk-config.

I have searched the web -> there are similare problems but none quite apply to mine.

Any suggestions??
 
Old 09-05-2003, 02:09 PM   #2
Maffuster
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
I've run into this problem before. The program isn't compatible with GTK 2.2 Install Version 1.2.10, and all your problems should go away!
 
Old 09-05-2003, 05:08 PM   #3
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
See the link below

http://www.linuxquestions.org/questi...002/11/2/34815
 
Old 09-05-2003, 08:58 PM   #4
a_morgan
LQ Newbie
 
Registered: Nov 2002
Location: BC, Canada
Distribution: Red Hat 9
Posts: 12

Original Poster
Rep: Reputation: 0
Thank you!

I followed the link. I needed to install glib-devel and gtkgtk+-devel. Now everything works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Bluefish. pkg-config missing Rodotheos Linux - Software 5 04-15-2005 04:54 AM
Installing Glib, ATK, GTK, Pkg Config, and Pango! LinuZ Linux - Newbie 9 10-26-2003 02:58 PM
Downloading Bluefish, what is gtk? CodeWarrior Linux - Software 3 07-30-2003 09:45 PM
new convert to slackware - problems installing bluefish editor though melquiades Slackware 11 07-06-2003 08:02 PM
GTK install/config, path problems greennick Linux - Software 3 09-18-2002 03:17 AM


All times are GMT -5. The time now is 03:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration