LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-28-2008, 11:00 AM   #1
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Rep: Reputation: 15
problem with installing "hplip" on RHEL4 x86_64


I need to instal "hplip" software on my RHEL4 x86_64 to configure
and manage my HP LaserJet 3052 printer/copier/scanner. CUPS utility
is not adequate for this purpouse

I failed to install "hplip" manually by following the instructions
http://hplip.sourceforge.net

# make
/bin/sh ./libtool --tag=CC --mode=link gcc -g -O2 -o cupsext.la -rpath /usr/lib64/python2.3/site-packages -module -avoid-version cupsext_la-cupsext.lo -lsane -lusb -lcups -lnetsnmp -lcrypto -ldl -ljpeg -lm -lpthread
gcc -shared .libs/cupsext_la-cupsext.o -lsane -lusb -lcups /usr/lib/libnetsnmp.so -lcrypto -ldl -ljpeg -lm -lpthread -Wl,-soname -Wl,cupsext.so -o .libs/cupsext.so

gcc: /usr/lib/libnetsnmp.so: No such file or directory
make: *** [cupsext.la] Error 1


Could anybody help me with this ? May be someone know how I can get
this /usr/lib/libnetsnmp.so library or may be somebody aware of rpm
hplip package for RHEL4 x86_64 on the internet.

I would really appreciate your help

Thank you,
John
 
Old 01-28-2008, 11:15 AM   #2
kalosaurusrex
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Rep: Reputation: 0
John,

Have you looked over the instructions here?

http://hplip.sourceforge.net/install...nterprise.html

I tested it awhile ago, it should work..in theory.

Hope this helps!

Aaron
HPLIP Support
 
Old 01-28-2008, 11:16 AM   #3
kalosaurusrex
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Rep: Reputation: 0
And just so you know the error:

gcc: /usr/lib/libnetsnmp.so: No such file or directory
make: *** [cupsext.la] Error 1

means you are probably missing the libsnmp-dev dependency.

Aaron
 
Old 01-28-2008, 11:43 AM   #4
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kalosaurusrex View Post
John,

Have you looked over the instructions here?

http://hplip.sourceforge.net/install...nterprise.html

I tested it awhile ago, it should work..in theory.

Hope this helps!

Aaron
HPLIP Support
Aaron,

Thanks a lot for your reply. I think this is exacly what happened
I missed libsnmp-dev dependecy and I do not have libsnmp-dev rpm
package on any installation disks which came with my RHEL4
distribution. I will try to find it on the Internet.
May be you can give me a helpful hint where I can find
reliable libsnmp-dev rpm package on the innet?

Thanks,

John
 
Old 01-28-2008, 12:29 PM   #5
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kalosaurusrex View Post
And just so you know the error:

gcc: /usr/lib/libnetsnmp.so: No such file or directory
make: *** [cupsext.la] Error 1

means you are probably missing the libsnmp-dev dependency.

Aaron
It seems this is not the case ... I checked - all packages
described in http://hplip.sourceforge.net/install...nterprise.html
are installed on my system.

It seems the package which contains libnetsnmp.so is called
net-snmp-devel in RHEL and it is installed.
Any other suggestions ?

Thanks,
John
 
Old 01-28-2008, 01:11 PM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
John

Not directly on point but: Centos is RedHat EL with the logos removed. You can run Centos rpms on RHel or the other way around. There is a howto on Centos for setting up RHEL4 to use yum and the Centos repos.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install RHEL4 in Xen of RHEL4--"unable to retrieve the install image" sailer_sh Red Hat 0 06-19-2007 12:31 AM
"Installing non-distro Linux on USB key" or "Using syslinux to boot a jffs2" lymae Linux - Newbie 6 12-31-2006 10:00 PM
HPLIP toolbox says "No installed HP device found" Mistreated Linux - Software 3 08-06-2006 10:07 PM
FTP problem "connection closed by remote host" with RHEL4 and Windows 2003 hooijack Linux - Enterprise 0 03-23-2006 09:29 PM
The problem about "cairo" in installing of "GTK" :( zhuqlfeixia Linux - Hardware 1 01-28-2006 03:12 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration