LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2004, 02:27 PM   #1
simquest
LQ Newbie
 
Registered: Jul 2002
Location: Quebec
Posts: 21

Rep: Reputation: 15
Problem openssl rpm upgrade


I want to upgrade my system. What is the problem ?

[root@ftp openssl]# rpm -Uvh ./openssl-0.9.7a-20.i386.rpm
warning: ./openssl-0.9.7a-20.i386.rpm: V3 DSA signature: NOKEY, key ID 9b8c94f5
error: Failed dependencies:
libcrypto.so.2 is needed by (installed) cyrus-sasl-md5-2.1.7-2
libcrypto.so.2 is needed by (installed) openldap-2.0.25-1
libcrypto.so.2 is needed by (installed) python-2.2.1-17
libcrypto.so.2 is needed by (installed) gnome-vfs2-2.0.2-5
libcrypto.so.2 is needed by (installed) bind-utils-9.2.1-9
libcrypto.so.2 is needed by (installed) lftp-2.5.2-5
libcrypto.so.2 is needed by (installed) libwvstreams-3.70-5
libcrypto.so.2 is needed by (installed) openssh-3.4p1-2
libcrypto.so.2 is needed by (installed) openssh-clients-3.4p1-2
libcrypto.so.2 is needed by (installed) openssh-server-3.4p1-2
libcrypto.so.2 is needed by (installed) pyOpenSSL-0.5.0.91-1
libcrypto.so.2 is needed by (installed) net-snmp-5.0.1-6
libcrypto.so.2 is needed by (installed) net-snmp-utils-5.0.1-6
libcrypto.so.2 is needed by (installed) sendmail-8.12.5-7
libcrypto.so.2 is needed by (installed) stunnel-3.22-4
libcrypto.so.2 is needed by (installed) tcpdump-3.6.3-3
libcrypto.so.2 is needed by (installed) wget-1.8.2-3
libcrypto.so.2 is needed by (installed) curl-7.9.8-1
libcrypto.so.2 is needed by (installed) ethereal-0.9.6-1
libcrypto.so.2 is needed by (installed) lynx-2.8.5-7
libssl.so.2 is needed by (installed) openldap-2.0.25-1
libssl.so.2 is needed by (installed) python-2.2.1-17
libssl.so.2 is needed by (installed) gnome-vfs2-2.0.2-5
libssl.so.2 is needed by (installed) lftp-2.5.2-5
libssl.so.2 is needed by (installed) libwvstreams-3.70-5
libssl.so.2 is needed by (installed) pyOpenSSL-0.5.0.91-1
libssl.so.2 is needed by (installed) sendmail-8.12.5-7
libssl.so.2 is needed by (installed) stunnel-3.22-4
libssl.so.2 is needed by (installed) wget-1.8.2-3
libssl.so.2 is needed by (installed) curl-7.9.8-1
libssl.so.2 is needed by (installed) lynx-2.8.5-7
openssl = 0.9.6b-29 is needed by (installed) openssl-devel-0.9.6b-2

or

[root@ftp openssl]# rpm -Uvh ./openssl-0.9.6b-32.7asp.i686.rpm
warning: ./openssl-0.9.6b-32.7asp.i686.rpm: V3 DSA signature: NOKEY, key ID 9b8c94f5
error: Failed dependencies:
openssl = 0.9.6b-29 is needed by (installed) openssl-devel-0.9.6b-29
 
Old 03-03-2004, 02:58 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 429Reputation: 429Reputation: 429Reputation: 429Reputation: 429
2 things are wrong:

the command is rpm - Uvh openssl-0.9.6b-32.7asp.i686.rpm
libssl.so.2 and libsypto.so.2 is needed

Get libssl.so.2 and libcrypto.so.2 first and then install openssl.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSSL Upgrade neodaemon Linux - Security 2 10-14-2005 01:40 PM
openssl rpm install problem canuck_12 Linux - Software 3 12-24-2003 09:56 AM
openssl.rpm rocketgo Linux - General 1 11-13-2003 10:20 PM
How do you upgrade openssl via rpm...? tarballed Linux - Software 6 10-02-2003 08:03 PM
openssl upgrade cuss Linux - General 12 03-11-2003 12:32 PM


All times are GMT -5. The time now is 12:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration