LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-10-2001, 01:57 AM   #1
lamco
LQ Newbie
 
Registered: Dec 2001
Location: malaysia
Distribution: RedHat
Posts: 3

Rep: Reputation: 0
Question Problem in Switching into GUI (runlevel 5)


hi, i m using RedHat 6.2 with 2.2.14 kernel and KDE1.x. I've used this GUI system for a few months without any login problem occurs. Only today, I've 1 problem... :

when the system successfully boot into system configuration, then normally it'll switch into run level 5, without any problem, afterwards, i can type login name and user password...
now, it fails to switch into run level 5, and the screen looks black out and blinking with a few green lines....
the system is trying to switch into GUI again n again but fail...

I've checked the VGA, monitor, they r in good condition. And i didnt change any setting after the latest safely shuting down.

Is there anybody can help me?

regards...
 
Old 12-10-2001, 01:23 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
usually in this case just try to reconfigure X first... are there anytype of error messages or does it keep attempting to start X?
if it is.. try this at lilo prompt to get past runleve 5 if you haven't tried yet:

Lilo: Linux 3

And that should put you in runlevel 3 at a command line login prompt.. from there try to reconfigure X before trying anything else.
 
Old 12-11-2001, 09:57 AM   #3
lamco
LQ Newbie
 
Registered: Dec 2001
Location: malaysia
Distribution: RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
dear trickykid

at the beginning, i thought this was due to config of X too, but when i try to login into runlevel 3, and reconfig X again, it seems the same prob happen.

So, i guest, it might due to the hardisk is fulled already and i didnt notice that. So, i try to move + erase some big directories in run level 3.

Finally, it works!!! And thanks for ur help... i really apprieciate ur help.

And the recent prob is i cannot access into internet after i fix the trouble. And i've checked the:
#netconf

it still remains as before. Is there any /etc/*.* has been corrupted and make the server cannot connect to internet?
Or i need to reconfigure some files in /etc?


regards
lamco
 
Old 12-11-2001, 12:52 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
how are you connecting to the net.. ethernet, modem.. etc??
 
Old 12-12-2001, 09:50 PM   #5
lamco
LQ Newbie
 
Registered: Dec 2001
Location: malaysia
Distribution: RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
dear buddy,

i've deleted /etc directory and replace a second copy of /etc from another hdd.
And it works, however i dont know which file had been corrupted.

thanks for ur support...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd behavior switching to runlevel 3 or shutting down sntnlz Linux - Hardware 4 11-28-2005 11:19 PM
switching gui mlbUC Linux - Newbie 10 04-09-2005 12:35 PM
Switching Runlevel Planky SUSE / openSUSE 13 02-13-2005 02:35 PM
Switching GUI BarfBag SUSE / openSUSE 7 12-13-2004 11:10 AM
switching to runlevel 3 sami Linux - Newbie 14 07-06-2003 08:41 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration