LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-10-2005, 08:37 AM   #1
Blue Jacket
Member
 
Registered: Oct 2005
Posts: 49

Rep: Reputation: 15
Unhappy Please help on "Mplayer plugin" failed when using "Make"


Hi guys,

Don't really know where and how to proceed. I have searched in this forum, but

could not find any solution .....

I have installed Mplayer and it works very nicely, no problem at all ...

But when I tried to install "Mplayer plugin" using the following steps:

[just a clue, I use Debian/Sarge and Gnome]

(1) I checked my version of firefox, it shows in "Help" --> "About" ...

rv: 1.7.10

(2) I went to the website of Mplayer plugin and downloaded the file:

"gecko-sdk 1.7.10" from Mozilla, and then extracted it.

(3) I downloaded the file "mplayerplug-in-3.11", and extracted it.

(4) When I started installing using the command "./configure", it showed an

error like: "gthread 2.0 not found".

(5) then, I launched the command "make", it showed some error message

and didn't proceed anymore.

==============================

I tried to look for the package "gthread 2.0" but could not find it in Debian



Does anyone have a solution for this, please


Thank you in advance, guys ...

Alez
 
Old 10-10-2005, 08:43 AM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
http://www.google.com/search?hl=en&l...n%C2%A0results
 
Old 10-10-2005, 12:27 PM   #3
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 966

Rep: Reputation: 34
did you read the "INSTALL" file in the mplayerplug-in package? ? ?

especially about the parameters telling ./configure where to find gecko-sdk and which gtk version to use (gtk2)
 
Old 10-11-2005, 03:03 AM   #4
Blue Jacket
Member
 
Registered: Oct 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Hi guys,

thanks a lot for your answers. I already did the things you

mentioned, but it seems that I don't get the plugin work

Alez
 
Old 10-11-2005, 12:35 PM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
I have installed mplayerplugin a number of times and as long as I did "./configure --with-gecko-sdk=/path/to/gecko-sdk" all went well.

Post up the commands you issued please.
 
Old 10-12-2005, 02:57 AM   #6
Blue Jacket
Member
 
Registered: Oct 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Hi, XavierP

I did exactly you told. I put my gecko-sdk folder in my home, so I did:

"./configure --with-gecko-sdk=/home/Alez/gecko_files/gecko-sdk",

but it didn't work

I tried both including and excluding the folder name "gecko-sdk" in the above command, they also didn't work.

I tried gecko-sdk for both versions, 1.6 and 1.7, and again

when I launched "Make", it showed me the error messages I mentioned.

I really don't know how to configure this, but anyway thank you for your reply.

Alez
 
Old 10-12-2005, 02:19 PM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Quote:
If you get this error during configure:
checking for mozilla-plugin... Package mozilla-plugin was not found in the pkg-config search path.

You need to use the gecko-sdk option. Using gecko-sdk 1.6 with an earlier version of mozilla seems to be ok. NOTE:Using the gecko 1.7 SDK with a 1.6 version of Mozilla does not work. Use gecko-sdk 1.6 for Mozilla 1.6.x and gecko-sdk 1.7 for Mozilla 1.7.x

If you can't figure out what you need try running

./whatoptions.sh

in the mplayerplug-in directory.
I got this from http://mplayerplug-in.sourceforge.net/install.php
 
Old 10-17-2005, 03:52 AM   #8
Blue Jacket
Member
 
Registered: Oct 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks for reply, XavierP

I actually did everthing that is recommended in the MplayerPlugin website, but I could not get that work unfortunately

However, I have switched to the MediaPlayerConnectivity which is one of the Mozilla Firefox extention, and it works nicely.

Thanks for your post again

Alez
 
Old 10-19-2005, 08:29 AM   #9
ssnkumar
LQ Newbie
 
Registered: Mar 2004
Location: Bangalore
Posts: 26

Rep: Reputation: 15
Quote:
Originally posted by Blue Jacket
Thanks for reply, XavierP

I actually did everthing that is recommended in the MplayerPlugin website, but I could not get that work unfortunately

However, I have switched to the MediaPlayerConnectivity which is one of the Mozilla Firefox extention, and it works nicely.

Thanks for your post again

Alez
Is this MediaPlayerConnectivity available for Solaris (on x86) also?

Regards,
Narendra
 
Old 10-20-2005, 03:29 AM   #10
Blue Jacket
Member
 
Registered: Oct 2005
Posts: 49

Original Poster
Rep: Reputation: 15
Hi ssnkumar,

I'm not sure, but in any case, you can check at the website:

http://membres.lycos.fr/sethnakht/

or

https://addons.mozilla.org/extension...nfo.php?id=446

have fun ! ,

Alez
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 05:51 AM
[Redhat] make "admin" account same privledges as "root" Bi0haZarD Linux - Networking 20 01-12-2005 11:47 AM
does failed using urpmi messed up my "Install Software" / "mandrake update" ??? sirpelidor Mandriva 1 11-02-2003 10:00 PM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 04:31 PM
i just finished typing "./configure" and "make" in mplayer directory... kublador Linux - General 4 02-22-2003 04:12 PM


All times are GMT -5. The time now is 03:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration