LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-26-2003, 09:30 PM   #1
firedude
LQ Newbie
 
Registered: Oct 2002
Location: Maryland
Distribution: Red Hat
Posts: 26

Rep: Reputation: 15
php installation problem


Hello all,
For the last 2 days I've been attempting to install php from source on my
RedHat/Fedora linux box. I am using Apach/httpd -2.0.47-10. I downloaded
the source version of php-4.3.4. I followed all the instructions that I
can find and I'm attempting to install php as a dso. The ./configure,
make and make install all seem to go fine; however once I restart apache
and attempt to bring up a php page all I see is the source code. I've
looked at my httpd source file and the LoadModule line for php is there.
I also added an AddType line for php. Below are the arguments that I
passed to ./configure:

./configure --enable-mysql --enable-exif --enable-pgsql
--with-apxs2=/usr/sbin/apxs
Can anyone offer me any assistance here as to what I might be doing or
have done wrong and how to correct it. Thanks alot.
AJ
 
Old 12-27-2003, 03:45 AM   #2
gregmcavoy
Member
 
Registered: Apr 2003
Location: Northern California, USA
Distribution: Debian
Posts: 54

Rep: Reputation: 15
You've probably already figured this out, but it took me a bit of time: If you just pull up your php file from a browser looking at your local machine (e.g. file:///var/www/html/index.php), apparently Apache never touches it and php looks like code. If you view it using an internet URL, it might work.
 
Old 12-27-2003, 04:44 AM   #3
hypexr
Member
 
Registered: Oct 2003
Location: USA Fresno Callifornia
Distribution: Gentoo (workstation), ArchLinux (file/mail server), Freebsd (web server), Ubuntu (laptop)
Posts: 115

Rep: Reputation: 16
This may help you.
tutorial
 
Old 12-27-2003, 09:10 AM   #4
firedude
LQ Newbie
 
Registered: Oct 2002
Location: Maryland
Distribution: Red Hat
Posts: 26

Original Poster
Rep: Reputation: 15
I figured out what the problem was. Apparently I wasn't moving the php.ini file into place. Now I have it working. Thanks to all for the help.
AJ
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add options in php.in after installation of PHP? touqeeransar Linux - Software 1 11-30-2005 04:52 AM
PHP installation problem ridge321 Linux - Newbie 6 02-06-2005 11:17 AM
New to PHP and Postgressql. Is this a PHP problem or a sql problem. Please help sendas4 Linux - General 2 11-05-2004 01:54 PM
php installation problem varala_kanth Linux - Software 1 06-07-2004 11:33 AM
PHP Installation problem tina_gora Programming 6 05-31-2001 11:47 PM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration