LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-23-2005, 05:32 AM   #1
terfy
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: openSUSE
Posts: 165

Rep: Reputation: 30
no sound on RealPlayer10GOLD (debian sarge)


I have problems with my sound..

When I start a .ram it counts seconds in RealPlayer as is should, but I cannot get any sound out of my speakers...

My systems sound and XMMS and Xine works fine with sound, but Realplayer is "mute"

Nothing happens when I adjust Kmix soundlevel, same soundlevel is used, even if I click mute too.. this is fuckin strange..

What can I do..
Plz help
 
Old 05-23-2005, 01:11 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
realplayer only supports OSS sound modules

see that u have that siupport and that it is free when u play real player
 
Old 05-24-2005, 05:37 AM   #3
terfy
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: openSUSE
Posts: 165

Original Poster
Rep: Reputation: 30
So

how do I fix it then ??

Do I have to buy a new sound-device ?? (IF yes, I'll get Audigy2 )

plz help.. A cannot use Kmix either.. even if I click mute on it, it still plays music with xmms and xine.. but realplayer is still mute..
 
Old 05-24-2005, 06:29 AM   #4
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i recompiled my kernel and build the OSS modules into that kernel and now real player works fine for me

regards
 
Old 05-24-2005, 11:08 AM   #5
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Install the alsa-oss package. I think that's what it's called but it might be a bit different. Then invoke realplayer with:

Code:
aoss realplay
If that doesn't work try:
Code:
export AUDIO=/dev/dsp0
aoss realplay
 
Old 05-24-2005, 05:18 PM   #6
terfy
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: openSUSE
Posts: 165

Original Poster
Rep: Reputation: 30
does not work.. it says

debian:/home/terfy# aoss realplay
Warning: LD_PRELOAD="/usr/lib/libaoss.so"
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


** ERROR **: Unable to open display
aborting...
/usr/bin/realplay: line 75: 4165 Aborted $REALPLAYBIN "$@"



how can I fix this ??
 
Old 05-25-2005, 03:06 AM   #7
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Well don't try to start realplayer when you're root. So logout of root in the terminal and then do it as normal user.
 
Old 05-25-2005, 04:06 AM   #8
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Quote:
Originally posted by darkleaf
Well don't try to start realplayer when you're root. So logout of root in the terminal and then do it as normal user.
will that make any difference?
 
Old 05-25-2005, 05:26 AM   #9
terfy
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: openSUSE
Posts: 165

Original Poster
Rep: Reputation: 30
doesn't help much..

it opens the realplayer without the error, but its still mute..

the
Warning: LD_PRELOAD="/usr/lib/libaoss.so"
are there still..
 
Old 05-25-2005, 07:17 AM   #10
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Did you try the line with export as well. The idea is oss is supposed to use the /dev/dsp0 while alsa just uses /dev/dsp. Though depending on your configuration it could be a different device too.

The LD_PRELOAD line is ok. That's what it's supposed to do.
 
Old 05-25-2005, 07:19 AM   #11
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Quote:
Originally posted by masand
will that make any difference?
Yes cause with su you're not allowed to make a connection to the xserver. Only as the user you're logged into as. That's the error message. So if user x logs in it's ok to run things from the terminal as user x but as root you won't be able to start GUI stuff.
 
Old 05-25-2005, 09:51 AM   #12
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
about the Xserver thin you are talking about
that is there with the login managers
but once u have logged in a GUI then u should not have any problem with starting any GUI application

regards
 
Old 05-25-2005, 10:07 AM   #13
terfy
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: openSUSE
Posts: 165

Original Poster
Rep: Reputation: 30
I did try with export too..

still mute.. AND as always I can't even change sound level in xine and xmms.. I can mute them when turning the sound bar all down in them, but only one level is coming out as low as well as high placement of the bar.. AND the kmix doesnt work at all.. not even the "mute" in it..

realplayer is still mute.. damn fuckin sound system..
 
Old 05-25-2005, 12:40 PM   #14
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
ok try this

get the real media plugins which is a part of the plugins pacage frm mplayerhq.hu

install those to /usr/lib/win32 and u can play real media files in xine as well

regards
 
Old 05-25-2005, 12:46 PM   #15
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Disable the kde sound server, it doesn't work properly anyway. Never got it to work. Do you have a sound card that does hardware mixing? If not, do you use a .asoundrc file to enable software mixing?

Masand on debian you can't start a program from the terminal as root user when you're logged in as normal user. You can do it using xhost but it's not secure and not recommended. Other than that you can run the programs with sudo or gksu but no way you'll be running things via su in a normal user environment by default.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound - Debian Sarge jrcreasy Linux - Newbie 7 08-27-2005 11:30 AM
Sound Problems in Debian Sarge Myrdos Debian 4 06-18-2005 06:39 PM
No sound on Debian sarge carloscuderia Linux - Newbie 5 04-08-2005 04:25 PM
Sound in Debian Sarge Kernel 2.6 quentusrex Debian 13 08-13-2004 11:44 PM
No sound on Debian sarge, kernel 2.6.5.1-k7 bruno buys Debian 4 07-12-2004 07:47 PM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration