LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-04-2003, 08:41 PM   #1
sk8guitar
Member
 
Registered: Jul 2003
Location: DC
Distribution: mandrake 9.1
Posts: 415

Rep: Reputation: 30
mplayer plays wmv video but sound is scrambled


hi, i installed mplayer (from the mandrake cd rpm, because mplayerhq.hu is not loading at all, i can't even ping them) and installed the win32 codecs and vids play fine but the sound is all scrambled. i'm not getting any audio codec errors in CL. here is what it says when i try and play a video

Code:
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer 0.90rc4-3.2.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel  (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetectio
Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: this codecs.conf is too old, incompatible
th this mplayer release! at line 6
Reading /etc/mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or dire
ry
Input config file /etc/mplayer/input.conf parsed : 52 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Movie.wmv
Cache fill:  0.00% (0 bytes)    ASF file format detected.
============ ASF Stream group == START ===
 object size = 38
 stream count=[0x2][2]
   stream id=[0x1][1]
   max bitrate=[0x57af][22447]
   stream id=[0x2][2]
   max bitrate=[0xf3157][995671]
============ ASF Stream group == END ===
VIDEO:  [WMV2]  512x384  24bpp
Clip info:
 author: www.feton.net
 copyright: All Rights Reserved
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 22050 Hz, 2 ch, 16 bit (0x10), ratio: 2751->88200 (22.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
vo: X11 running at 1400x1050 with depth 24 and 32 bpp (":0.0" => local displa
Disabling DPMS
==========================================================================
Opening video decoder: [dshow] DirectShow video codecs
Decoder supports the following YUV formats: YUY2 IYUV UYVY YV12 YVYU I420 YVU
Decoder is capable of YUV output (flags 0x7f)
VDec: vo config request - 512 x 384 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 4.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 512x384 => 512x384 Planar YV12  [fs]
Selected video codec: [wmv8] vfm:dshow (Windows Media Video 8)
==========================================================================
Checking audio filter chain for 22050Hz/2ch/16bit -> 22050Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 22050 hz, little endian signed int 
AF_pre: 22050Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 22050Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 22050Hz/2ch/16bit -> 22050Hz/2ch/16bit...
Starting playback...
A:  46.7 V:   8.1 A-V: 38.608 ct:  0.514  155/155  18%  6%  1.5% 0 0 49%

MPlayer interrupted by signal 2 in module: enable_cache


MPlayer interrupted by signal 2 in module: sleep_rtc
Total Unfree 1706550 bytes cnt 154 [(nil),0]
Successfully enabled DPMS
any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer codec rv40 plays rmvb video, but no sound... sirpelidor Linux - Software 5 12-04-2008 07:12 PM
xine - plays sound but no video edudlive Linux - Software 3 08-29-2004 08:17 PM
xine plays only (a part of) the sound of a wmv, some divx files and crushes mp4 files bezoomny Linux - Software 1 03-10-2004 08:33 PM
Mplayer plays sound but not video. help! mordin Linux - Software 5 10-27-2003 02:59 PM
mplayer plays tv but what about tv's s-video input? bkeating Linux - Software 2 09-09-2003 06:12 AM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration