LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-13-2012, 09:48 AM   #1
kirk5000
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Rep: Reputation: Disabled
mono: error running custom app via mono on linux RH


When I try to launch my C# application on our red hat enterprise system via the .NET emulator known as mono (v2.5.2), I get the following error:

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.

I have installed mono in another location than the one mentioned in the error message and I do see the mscorlib.dll in that location so my question is:
How does mono resolve that location and can I configure mono to find it where it's at?

Thanks in advance for any help on this.

Last edited by kirk5000; 06-13-2012 at 06:16 PM.
 
Old 06-13-2012, 06:15 PM   #2
kirk5000
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Question Would this be the windoze version of LD_LIBRARY_PATH?

I'm thinking it is but I don't know the windoze equivalent.
I've tried a number of things that the mono web site and other google results suggested but to no avail.
Again, any help is appreciated!
 
Old 06-13-2012, 11:46 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,919

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
kirk5000 you probably already know this but

you might want to port that code off the MS only language C# to a normal everyday language C++

mono dose NOT support all the Microsoft c# API's

Quote:
I have installed mono in another location than the one mentioned
???????????? how ?????
mono is in the RHN repo
the RECOMMENDED way is to use yum
Code:
su -
yum install mono
if you put a second install of mono someplace on the system you most likely broke it

you might want to ask red hat
the documentation for RHEL 6 and the older 5
https://access.redhat.com/knowledge/...erprise_Linux/
do a search of the Red hat knowledge base for "mono"

https://access.redhat.com/knowledge/...en&cid=2474740

you WILL need to log in to your rhn account to use the knowledge base

Last edited by John VV; 06-13-2012 at 11:54 PM.
 
Old 06-15-2012, 01:06 AM   #4
kirk5000
LQ Newbie
 
Registered: Jun 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
The target machine is a company resource

Quote:
???????????? how ?????
mono is in the RHN repo
the RECOMMENDED way is to use yum
The target machine is a company resource and Yum is not an option for me.
mono was installed from the source code via configure make install with the appropriate --prefix option.
 
Old 06-15-2012, 04:22 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,919

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
if your system admin can NOT install it from RHN you might be out of luck

I would get the administrator to install the correct version for mono from RHN for this version of RHEL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to create RPM for RHEL 6 to deploy a Mono Binary, with Mono 2.8.2 as a dependency bmoran Linux - Software 2 06-04-2012 09:53 AM
Mono 1.1.12 - Install older mono to co-exist with current version ryerke Linux - Software 4 03-02-2010 08:54 PM
app send-receive performance problem running using Linux (Mono) @alex Linux - General 0 02-25-2009 07:52 AM
Help Mono Installed But Mono Develop Won't Load TheGreatGonzo Slackware 8 05-18-2006 06:42 AM
LXer: Running .Net applications on Linux with Mono LXer Syndicated Linux News 0 04-26-2006 02:54 PM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration