LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-13-2010, 11:10 PM   #1
auftbl
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Rep: Reputation: 0
Missing php_gd2.dll (I tried yum install php-gd)


This could just have easily gone under Linux Newbie since I have no idea what I am doing, but since it is a software question I thought I would try this forum.

I am missing the GD library on my server so the Captcha is not working.
I looked for the php_gd2.dll in the php.ini but did not see it anywhere.

I am running Fedora 11.0-64 and PHP 5.2.13.

The steps I have tried are:
From the root doing "yum install php-gd"
Then did a "service httpd restart"
I did a grep of various pieces of "extension=php_gd2.dll" in the php.ini but did not see this line anywhere.

My file path is /etc/php.ini

Is there some where else I should be looking? Other steps I can take?
 
Old 10-13-2010, 11:27 PM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Did you install even devel packages for gd ?

Try it may solve your problem:

Code:
yum -y install gd-devel
 
Old 10-13-2010, 11:37 PM   #3
auftbl
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by prayag_pjs View Post
Hi,

Did you install even devel packages for gd ?

Try it may solve your problem:

Code:
yum -y install gd-devel
Yes. I had tried that.
I did it again just to be save but go "already installed and latest version".

Any other thoughts?
The php_gd2.dll should be in the php.ini file right?
 
Old 10-13-2010, 11:58 PM   #4
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
You said its not included;but its there in my fedora.What you do is serach inside the file.Its commented.

PHP includes a version of gd as "standard equipment." php_gd2.dll is included in a standard PHP installation which is not enabled by default. To turn it on, the user may simply uncomment the line "extension=php_gd2.dll" in php.ini and restart the PHP extension.

Change:

Quote:
#extension=php_gd2.dll
To:

Quote:
extension=php_gd2.dll
You may also have to correct the extension directory setting from:
Quote:
extension_dir = "./"
Or:
Quote:
extension_dir = "./extensions"

Last edited by prayag_pjs; 10-13-2010 at 11:59 PM.
 
Old 10-14-2010, 12:13 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,937

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
@OP

dll files are windows dynamic libraries. For linux the dynamic (shared) library should be gd.so.
Since you used yum to install php-gd, I guess it's already installed. To verify, run fro CLI:
Code:
php -i|grep GD
You need also to restart the web server in order to use the extension.

Regards
 
Old 10-14-2010, 12:13 AM   #6
auftbl
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
prayag_pjs, thanks for the help.
Bear with me as I am new at this.

From the directory /root/etc

I type

grep "php_gd2.dll" php.ini

and nothing shows up.

I type in

grep extension php.ini

and all I get is

"[root@server2 etc]# grep extension php.ini
; dynamically loaded extension (either a PHP extension or a Zend extension),
; you may only use these constants *after* the line that loads the extension.
; leading '/'. You must also specify the file extension being used including
; If you wish to have an extension loaded automatically, use the following
; extension=modulename.extension
; extension=msql.so
; needs to go here. Specify the location of the extension with the
; extension_dir directive above.
; Note: packaged extension modules are now loaded via the .ini files
; Sets the directory name where SOAP extension will put cache files.
[root@server2 etc]#


so I don't see the line I am supposed to uncomment.

Am I in in the wrong file? wrong directory? Missing complete chunks of code?

Thanks for the help!
 
Old 10-14-2010, 12:28 AM   #7
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

What you do is add the line manually in file.
 
Old 10-14-2010, 10:56 PM   #8
auftbl
LQ Newbie
 
Registered: Oct 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks! I will add it now.

I appreciate the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update PHP on CentOS - missing dependency php-common AndyMillne Linux - Server 7 05-21-2013 06:34 AM
Getting Error: Missing Dependency: php-common, when trying to install php-soap amish123 Linux - Software 3 02-18-2010 07:26 PM
yum install PHP: yum tries to install duplicate httpd beebopbogo Linux - Software 1 05-26-2009 02:08 AM
winxp reinstall w/grub manual install on ubuntu causes missing hal.dll file for xp pulper Linux - Software 6 09-13-2006 02:26 PM
Missing Dependencies during Yum Install? keysorsoze Fedora 4 01-17-2005 12:01 AM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration