LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-13-2004, 05:15 PM   #1
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Rep: Reputation: 15
Linking Problem I think?


I am trying to compile Eterm for the transparencey option, and thats the only thing I cant get to work. I have downloaded imlib2 and compiled it with no errors. (imlib2-1.1.1.tar.gz) Is there a difference in Imlib2 and imlib2, is it just a matter of the "i" being capitalized, is it that I need to rename "imlib2" or the dir? Should I just be linking the lib file to another file? If so should I be linking /usr/local/bin/imlib2 to something? Strange cause thats a /bin file. I'm a little confused. I know I can do whatever has to be done, I just need a hint or a push in the right direction..
Here is some output from the compile and a couple of whereis's. I will post more output if needed. Any help would be great.

thanks
gplacek

configure: warning: *** Pixmap support has been disabled because Imlib2 was not found ***
configure: warning: *** or could not be linked. Eterm should still work
configure: warning: *** not be very happy. Check config.log for more detailed ***
configure: warning: *** information on why my attempt to link with Imlib2 failed. ***

$ whereis imlib2
imlib2: /usr/local/bin/imlib2

$ whereis Imlib2
Imlib2:
 
Old 08-13-2004, 06:08 PM   #2
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
Unhappy can I get a hint please

Does anyone think that this is a linking problem or that imlib2 is named wrong. I just need a little hint here, can someone tell me what they think? :-)

gplacek
 
Old 08-13-2004, 06:09 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
The easiest thing to do, really, would be to
edit ./configure and see whether the capitalisation
only happens in the output for that error-message
or whether it actually is (stupidly) looking for a
libImlib2 ...


Cheers,
Tink
 
Old 08-13-2004, 06:27 PM   #4
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
ok..

All the references to Imlib2 , the "I" is capital. Here is a clip from my configure file. Did I install Imlib2 in the wrong place or it cant find it because it is spelled "imlib2"? Can I fix this by linking it, and if so, how should I make the link. I knw to use "ln" but I've never made a link before. Do I need to go to the /usr/local/lib/ and link using a different name to my install dir in /home/greg/Eterm/ or what? Thanks for the help.

gplacek

ps. It looks like it says -LImlib2 with a lowercase "L" before the "i"

echo $ac_n "checking for imlib_create_image in -lImlib2""... $ac_c" 1>&6
echo "configure:8913: checking for imlib_create_image in -lImlib2" >&5
ac_lib_var=`echo Imlib2'_'imlib_create_image | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
 
Old 08-13-2004, 06:37 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Try a
locate -i libimlib2
to find out whether it's actually capitalised or
not ... if it's not it's pretty safe to assume that
the ./confugire script is stuffed, and you could
try editing that ...


Cheers,
Tink
 
Old 08-13-2004, 06:48 PM   #6
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
Looks like all the instances are capital "I". But what does this tell me? Does the -i stand for case insensitive? But in my /home dir the dir name is lowercase, does this matter, I dont think so. I should be looking at the ones in the /local/lib/ dir, right? what should I do about this? Should I be linking them? Why is the configure not finding them? Youve been lots of help Tinkster, :-) I feel I am getting close to the answer. Thanks

gplacek

$ locate -i libimlib2
/usr/local/lib/libImlib2.so.1.1.1
/usr/local/lib/libImlib2.so.1
/usr/local/lib/libImlib2.so
/usr/local/lib/libImlib2.la
/usr/local/lib/libImlib2.a
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.so.1.1.1
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.so.1
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.so
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.a
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.lai
/home/greg/eterm/imlib2/imlib2-1.1.1/src/.libs/libImlib2.la
/home/greg/eterm/imlib2/imlib2-1.1.1/src/libImlib2.la
 
Old 08-13-2004, 06:53 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
In this case the next thing to check would be
whether FC actually adds /usr/local/lib to
the ld-path ...

Edit /etc/ld.so.conf
If /usr/local/lib isn't in there, add it and run
ldconfig ... then try your compile again.


Cheers,
Tink
 
Old 08-13-2004, 07:08 PM   #8
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
ok. /usr/local/lib wasnt there but I added

ok. /usr/local/lib wasnt there but I added it. I want to run "ldconfig". I read the man page (not very long) but I am a little foggy on what options I need to use..

Some existing libs do not contain enough information to allow the
deduction of their type, therefore the /etc/ld.so.conf file format
allows the specification of an expected type. This is only used for
those ELF libs which we can not work out. The format is like this
"dirname=TYPE", where type can be libc4, libc5 or libc6. (This syntax
also works on the command line). Spaces are not allowed. Also see the
-p option.

should I

ldconfig /usr/local/lib=TYPE? Which type? or am I using the wrong option?

Thanks lots

gplacek :-)
 
Old 08-13-2004, 07:38 PM   #9
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
Angry ahhhhh

This is driving me crazy... I feel like I was so close... I know about what I am doing and the I keep getting bash: ldconfig: command not found.... ahhhh .. I am running as root and I for the life of me cant get ldconfig to do a thing. I've read the man page, and no matter what I do I cant get ldconfgi to do anything. what could I possibly be missing...

gplacek
 
Old 08-13-2004, 07:42 PM   #10
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
ok ok... I guess I wasnt working in the /sbin dir... blaaaaa
 
Old 08-13-2004, 08:01 PM   #11
gplacek
Member
 
Registered: Aug 2004
Location: Atlanta
Distribution: Slackware
Posts: 56

Original Poster
Rep: Reputation: 15
Unhappy Still no luck

This is really bugging me. and to think all I wanted was to use Eterm so I could have that nice transparent look for my term while I use window maker, I seem to be giving myself a crash course in linking failure.

any help would be great.
thanks
gplacek

I have edited and /sbin/ldconfig and then configured

$ locate -i libimlib2
/usr/local/lib/libImlib2.so.1.1.1
/usr/local/lib/libImlib2.so.1
/usr/local/lib/libImlib2.so
/usr/local/lib/libImlib2.la
/usr/local/lib/libImlib2.a

/etc/ld.so.conf

/usr/X11R6/lib
/usr/lib/sane
/usr/lib/qt-3.1/lib
/usr/local/lib ....... so I added this line

then

"Edit /etc/ld.so.conf
If /usr/local/lib isn't in there, add it and run
ldconfig ... then try your compile again."

/usr/local/lib:
libfreetype.so.6 -> libfreetype.so.6.3.7
libwraster.so.2 -> libwraster.so.2.2.0
libdha.so.1.0 -> libdha.so.1.0
libImlib2.so.1 -> libImlib2.so.1.1.1
libEterm-0.9.2.so -> libEterm.so
libast.so.1 -> libast.so.1.1.0

BUT, I still get the same error message during configure

configure: warning: *** Pixmap support has been disabled because Imlib2 was not found ***
configure: warning: *** or could not be linked. Eterm should still work
configure: warning: *** not be very happy. Check config.log for more detailed***
configure: warning: *** information on why my attempt to link with Imlib2 failed ***
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ld linking problem captain-mythos Linux - Software 1 06-20-2004 09:46 AM
Library linking problem The_Nerd Programming 10 04-27-2004 12:07 AM
C++ Linking Problem acjt Programming 4 01-31-2004 09:48 AM
Problem linking Red Guy Programming 1 02-07-2003 04:52 AM
linking problem with ld ! gluon Programming 2 05-19-2002 02:59 PM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration