LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-11-2004, 05:58 PM   #1
jib2
Member
 
Registered: Sep 2003
Location: Paris, France
Distribution: Arch x86_64
Posts: 221

Rep: Reputation: 30
libraries conflict


(Mdk 9.1)
Im trying to get gotmail running, but it needs curl-ssl.
I tried installing curl-ssl-7.10.4-1.i386.rpm (latest version available) but it wont install cuz 2 libraries are missing : libcrypto.so.2 and libssl.so.2
These libraries are part of openssl096b package, but i have already a newer version (openssl-0.9.7a) installed with libcrypto.so.0 and libssl.so.0
So should i still install curl-ssl-7.10.4-1 with the --nodeps flag? What other option do i have?
Thanks for your help (i found no information about this problem).
 
Old 01-12-2004, 05:16 AM   #2
deamion
LQ Newbie
 
Registered: Jan 2004
Location: Rijswijk
Distribution: Red Hat, Suse and FreeBSD
Posts: 2

Rep: Reputation: 0
I have the same problems with pyOPenSSl, it needs the libcrypto.so.4 and libssl.so.4, but I cant' update openssl, cause there are some packages that needs the libcrypto.s0.4 and libssl.so.2.. How can I get the.4 files and keep the .2 files.. There are quite a number of packages that needs the .2 files, so i am not really looking forward in updating them all..

Any help?
 
Old 02-03-2004, 08:03 AM   #3
joncoles
LQ Newbie
 
Registered: Feb 2004
Distribution: Ubuntu 12.10, Slackware 14.0
Posts: 11

Rep: Reputation: 0
If you look closely at /usr/lib you can see that some lib<whatever>.so.2 files are just symlinks to some other version of the library.

In the case of libssl.so.2, I find that the openssl096b package, when examined with Midnight Commander, does not contain libssl.so.2, but rather libssl.so.0.9.6b. Perhaps a symlink would be created on install. I already have libssl.so.0.9.6 and libssl.so.0.9.7.

The existence of a lib<whatever>.so.<number> file is sometimes ignored by urpmi. It complains that it needs this file, which you already have. RPM is one of those nice ideas that doesn't always work. The solution sometimes is to get the tarball (tar.gz) version of what you are trying to install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Conflict? ltcolfury Linux - Software 2 11-03-2005 09:29 AM
conflict with install cptnchainsaw Linux - General 3 05-05-2005 02:59 PM
xp conflict with slackware Gunslinger_ROL Slackware 3 09-11-2004 10:29 PM
Hardware Conflict thundersnows Linux - Hardware 3 08-18-2003 11:31 PM
conflict between NIC w3bbuilder Linux - Networking 4 08-15-2003 06:28 AM


All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration