LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-31-2009, 08:18 AM   #1
cyclops.matrix
Member
 
Registered: May 2006
Location: London - Matrix
Distribution: Open Suse 11.1
Posts: 50

Rep: Reputation: 15
Installing vmware on Open Suse 11.1 - Requires original gcc 4.32 - gcc now 4.3


Previously created thread
Installing vmware on suse 11.1 - comp issue gcc 4.32 and 4.3

Can anyone assist here please

Trying to install vmware on Open Suse linux 11.1
However i am still having trouble with the install as it keeps requesting the original gcc compiler, despite efforts
Any ideas as to how to move forward or alternative steps to take - I will now try to remove the original install and try again from scratch.

Thanks


Current System Spec.
Open Suse Linux 11.1 kernel 2.2.27.25-0.1 with windows xp duel boot system
KDE 4.3.0 R 155
AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
Speed:1,000.00 MHz
Memory 2.0 GB
Video: Rasterizer 2.1 Mesa 7.2
 
Old 08-31-2009, 12:15 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,391

Rep: Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529
Quote:
Originally Posted by cyclops.matrix View Post
Previously created thread
Installing vmware on suse 11.1 - comp issue gcc 4.32 and 4.3

Can anyone assist here please

Trying to install vmware on Open Suse linux 11.1
However i am still having trouble with the install as it keeps requesting the original gcc compiler, despite efforts
Any ideas as to how to move forward or alternative steps to take - I will now try to remove the original install and try again from scratch.

Thanks


Current System Spec.
Open Suse Linux 11.1 kernel 2.2.27.25-0.1 with windows xp duel boot system
KDE 4.3.0 R 155
AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
Speed:1,000.00 MHz
Memory 2.0 GB
Video: Rasterizer 2.1 Mesa 7.2
The other thread you opened for this had a solution, and it was noted by the original responder, that you made errors in the commands. Did you re-run the solution with the correct commands, and what error(s) did you get after doing so?
 
Old 08-31-2009, 02:52 PM   #3
cyclops.matrix
Member
 
Registered: May 2006
Location: London - Matrix
Distribution: Open Suse 11.1
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TB0ne View Post
The other thread you opened for this had a solution, and it was noted by the original responder, that you made errors in the commands. Did you re-run the solution with the correct commands, and what error(s) did you get after doing so?
Thanks for getting back
Although i am grateful for Chris input i have followed his post , my apologies if i have used the wrong command here i have tried again and still no further forward not sure what i have missed

My current gcc is 4.3 need to move to 4.3.2

This is the result

# which gcc
# which gcc-4.3
# cd /usr/bin
# ln -s gcc-4.3 gcc --force
# which gcc
# ls -l /usr/bin | grep "gcc"
gcc-4.3
#

rwxr-xr-x 1 root root 5692 2008-12-03 08:10 pbmtobbnbg
-rwxr-xr-x 1 root root 5708 2008-12-03 08:10 pbmtocmuwm
-rwxr-xr-x 1 root root 5712 2008-12-03 08:10 pbmtodjvurle
-rwxr-xr-x 1 root root 9792 2008-12-03 08:10 pbmtoepsi
-rwxr-xr-x 1 root root 9800 2008-12-03 08:10 pbmtoepson
-rwxr-xr-x 1 root root 9804 2008-12-03 08:10 pbmtoescp2
-rwxr-xr-x 1 root root 13888 2008-12-03 08:10 pbmtog3
-rwxr-xr-x 1 root root 9804 2008-12-03 08:10 pbmtogem
-rwxr-xr-x 1 root root 9800 2008-12-03 08:10 pbmtogo
-rwxr-xr-x 1 root root 9820 2008-12-03 08:10 pbmtoibm23xx
-rwxr-xr-x 1 root root 5700 2008-12-03 08:10 pbmtoicon
-rwxr-xr-x 1 root root 9824 2008-12-03 08:10 pbmtolj
-rwxr-xr-x 1 root root 9804 2008-12-03 08:10 pbmtoln03
-rwxr-xr-x 1 root root 9804 2008-12-03 08:10 pbmtolps
-rwxr-xr-x 1 root root 9800 2008-12-03 08:10 pbmtomacp
-rwxr-xr-x 1 root root 5696 2008-12-03 08:10 pbmtomatrixorbital
-rwxr-xr-x 1 root root 9816 2008-12-03 08:10 pbmtomda
-rwxr-xr-x 1 root root 5692 2008-12-03 08:10 pbmtomgr
-rwxr-xr-x 1 root root 9800 2008-12-03 08:10 pbmtomrf
-rwxr-xr-x 1 root root 9820 2008-12-03 08:10 pbmtonokia
-rwxr-xr-x 1 root root 5700 2008-12-03 08:10 pbmtopgm
-rwxr-xr-x 1 root root 5696 2008-12-03 08:10 pbmtopi3
-rwxr-xr-x 1 root root 18380 2008-12-03 08:10 pbmtopk
-rwxr-xr-x 1 root root 5680 2008-12-03 08:10 pbmtoplot
-rwxr-xr-x 1 root root 26228 2008-12-03 08:10 pbmtoppa
-rwxr-xr-x 1 root root 11524 2008-12-03 08:10 pbmtopsg3
-rwxr-xr-x 1 root root 5688 2008-12-03 08:10 pbmtoptx
-rwxr-xr-x 1 root root 5680 2008-12-03 08:10 pbmtowbmp
-rwxr-xr-x 1 root root 9808 2008-12-03 08:10 pbmtox10bm
-rwxr-xr-x 1 root root 9820 2008-12-03 08:10 pbmtoxbm
-rwxr-xr-x 1 root root 5692 2008-12-03 08:10 pbmtoybm
-rwxr-xr-x 1 root root 9804 2008-12-03 08:10 pbmtozinc
-rwxr-xr-x 1 root root 13880 2008-12-03 08:10 pbmupc
-rwxr-xr-x 1 root root 5692 2008-12-03 08:10 pc1toppm
-rwxr-xr-x 1 root root 30848 2009-05-14 11:04 pcl3opts
-rwxr-xr-x 1 root root 9844 2009-02-22 12:45 pcprofiledump
-rwxr-xr-x 1 root root 27100 2008-12-03 05:02 pcregrep
-rwxr-xr-x 1 root root 42716 2008-12-03 05:02 pcretest
-rwxr-xr-x 1 root root 13912 2008-12-03 08:10 pcxtoppm
-rwxr-xr-x 1 root root 735 2009-05-14 11:03 pdf2dsc
-rwxr-xr-x 1 root root 940 2009-05-14 11:03 pdf2ps
-rwxr-xr-x 1 root root 14212 2008-12-03 10:32 pdffonts
-rwxr-xr-x 1 root root 26532 2008-12-03 10:32 pdfimages
-rwxr-xr-x 1 root root 18468 2008-12-03 10:32 pdfinfo
-rwxr-xr-x 1 root root 581 2009-05-14 11:03 pdfopt
-rwxr-xr-x 1 root root 10052 2008-12-03 10:32 pdftoabw
-rwxr-xr-x 1 root root 71976 2008-12-03 10:32 pdftohtml
-rwxr-xr-x 1 root root 14252 2008-12-03 10:32 pdftoppm
-rwxr-xr-x 1 root root 14212 2008-12-03 10:32 pdftops
-rwxr-xr-x 1 root root 18500 2008-12-03 10:32 pdftotext
-rwxr-xr-x 1 root root 5286 2008-12-03 12:25 pdiff
-rwxr-xr-x 1 root root 9816 2009-03-12 15:51 peekfd
-rwxr-xr-x 3 root root 2469692 2009-06-10 17:25 perl
-rwxr-xr-x 3 root root 2469692 2009-06-10 17:25 perl5.10.0
-rwxr-xr-x 1 root root 38130 2009-06-10 17:24 perlbug
-rwxr-xr-x 1 root root 224 2009-06-10 17:24 perldoc

(This tex has been shortened as it was too large)

/bin #

re ran vmware

# vmware-config.pl
Making sure services for VMware Server are stopped.

Stopping VMware autostart virtual machines:
Virtual machines failed
Stopping VMware management services:
VMware Virtual Infrastructure Web Access
VMware Server Host Agent failed
Stopping VMware services:
VMware Authentication Daemon done
Virtual machine monitor done

None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes] yes

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

Your kernel was built with "gcc" version "4.3.2", while you are trying to use
"/usr/bin/gcc" version "4.3". This configuration is not recommended and VMware
Server may crash if you'll continue. Please try to use exactly same compiler as
one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.3" anyway? [no] no

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/go/unsup-linux-products" and
"http://www.vmware.com/go/unsup-linux-tools".

Execution aborted.

# vmware-config.pl
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have an error Building GCC: requires GMP 4.1+ and MPFR 2.3.0+. robineecc1 Linux From Scratch 14 10-03-2011 09:41 PM
Installing vmware on suse 11.1 - comp issue gcc 4.32 and 4.3 cyclops.matrix Linux - Software 7 04-01-2009 10:46 AM
Debian apt-get requires cdrom for gcc install dwebst Linux - Software 1 05-04-2007 12:05 PM
Gcc requires ...gcc? rose_bud4201 Suse/Novell 6 06-13-2005 11:25 AM
Installing Gcc (it requires a compiler) funkatron Linux - Software 2 09-25-2004 10:38 AM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration