LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-08-2008, 12:00 AM   #1
elliotfuller
Member
 
Registered: Apr 2005
Location: San Francisco, CA
Distribution: Ubuntu, Debian
Posts: 83

Rep: Reputation: 15
Install grub with knoppix on hardware RAID 5


I just installed a debian based distro on my Dell poweredge 2900. It comes with a perc 5/i raid card which actually translates to a MegaRAID 8408E card, but dell likes to slap there name on it.

The install went okay, except for grub. I get the classic failed to install grub to hd(0,0) message and I am left with an un-bootable system.

The configuration is RAID 5, and the installer is labeling the partitions as /dev/sda1 and /dev/sda2 (root and swap respectively).

I booted in with knoppix to install grub, but knoppix doesn't recognize the individual disks so i cant install grub on the first hard drive.

Its been awhile since I have installed grub, so i tried a few things...

Here is my fstab from the boot disk

Code:
proc      /proc       proc   rw,nosuid,nodev,noexec 0 0
/sys       /sys        sysfs  rw,nosuid,nodev,noexec 0 0
/dev/shm   /dev/shm    tmpfs  rw,nosuid,nodev,noexec 0 0
/dev/pts   /dev/pts    devpts mode=0622           0 0
/dev/fd0   /media/fd0  auto   user,noauto,exec,umask=000    0 0
/dev/cdrom /media/cdrom  auto   user,noauto,exec,ro 0 0
/dev/hda /media/hda  auto   users,noauto,exec,ro 0 0
# Added by KNOPPIX
/dev/sda1 /media/sda1 ext3 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/sda2 /media/sda2 auto noauto,users,exec 0 0
So I blunderingly tried..

Code:
grub> root (hd0,0)
 Filesystem type unknown, partition type 0xee

grub>
to no avail..

and I even tried,
Code:
root@Knoppix:/mnt# grub-install /dev/hda
/dev/hda does not have any corresponding BIOS drive.
root@Knoppix:/mnt# grub-install /dev/sda
Could not find device for /boot: Not found or not a block device.
root@Knoppix:/mnt# grub-install /dev/sda1
Could not find device for /boot: Not found or not a block device.
to no avail..

Any idea how to get knoppix to write grub to the MBR of the first disk?

I gotta have this system running!
 
Old 06-08-2008, 01:09 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
until you get a better reply...I do not use raid...I believe you will have more relable success if you make a separate /boot partition for grub to work with....here are some images and notes on howto

edit wrong link try

http://www.linuxquestions.org/questi...83#post3074583

Last edited by aus9; 06-08-2008 at 01:11 AM.
 
Old 06-08-2008, 01:31 PM   #3
elliotfuller
Member
 
Registered: Apr 2005
Location: San Francisco, CA
Distribution: Ubuntu, Debian
Posts: 83

Original Poster
Rep: Reputation: 15
Looks like grub cant install on a partition larger than 2 TB. I'm gonna verify that this is the reason for the failed install this afternoon.
 
Old 06-08-2008, 08:17 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
agreed but it appears to affect lilo as well
http://www.unixgods.org/~tilo/linux_larger_2TB.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Fedora4 with hardware RAID on HP Proliant ML110 baddah Fedora 4 09-18-2006 03:26 AM
FC4 Install with Hardware RAID 5 EviLBoX Fedora 3 09-14-2006 12:22 PM
Knoppix 4.0 install did not update Grub upchucky Linux - Newbie 4 12-11-2005 08:02 PM
hardware raid -SUSE install how to annamma Linux - Hardware 1 12-28-2004 09:53 AM
i want to install Hardware RAID controller but confused ranixlb Linux - Hardware 0 08-16-2004 08:47 AM


All times are GMT -5. The time now is 02:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration