LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-17-2003, 12:35 AM   #1
theparadigm
Member
 
Registered: Nov 2003
Location: Australia :)
Posts: 36

Rep: Reputation: 15
Unhappy IMAP works but IMAP TLS doesn't under PHP (Horde IMP)


I've been trying to get Secure IMAP working under Horde Webmail without any luck.

I currently have IMAP authentication (without encryption) working using the below without a problem, it is just when I try to use IMAP TLS, it doesn't authenticate correctly (i don't know how to check any more than that.. i don't have physical access to the [NT] mail server ).

My 'architecture' is as follows:
A Linux box runs as the webserver (Apache 2.0.40-21.5) with the webmail client (Horde IMP 3.2 under PHP 4.2.2-17.2) on an internal network (network 1). The box then establishes a connection to an external static ip [via a linux router] to a port [specified above 40000] on that linux router (network 2), which in turn, masquerades the [tcp/udp] connection to an internal mail server (running MS Exchange 5.5.2653.13 under NT).
Just to note: It is not possible to create a secure tunnel between the 2 networks

Webserver
|
| (network 1)
Router
|
---------
INTERNET
---------
|
Router
| (network 2)
|
Mail Server

I'm using IPCHAINS (1.3.10-10) on the second router and ipmasqadm (0.4.2-4) to masquerade connections from the network1 to the internal exchange mail server on network 2.
I'm using a port [above 40000] for masquerading because we already have a TLS server accessable on port 993 to the outside on the second router.

I'm gussing, ... that possible causes as to why IMAP TLS doesn't work could be:....
- IMAP TLS negotiations can 'only' occur on port 993?
- Horde IMP WebMail doesn't support IMP TLS to an exchange server?
- IMAP TLS uses both UDP and TCP for transport?
... too many others

Any Horde IMP server configuration examples out there using IMAP TLS/SSL for an exchange server?
Any examples from anyone with an external webserver to internal mail server?
Any masquerading thoughts on using IMAP TLS?

It's a mess I know Sorry
(I've got so many other important things on my mind atm !:'( )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qmail-ldap + courier-imap woes (imap capability) syahid Linux - General 1 10-12-2005 12:03 AM
IMP+Horde on PHP 4.3.7 Ryand833 Linux - Software 0 07-04-2004 12:58 PM
Horde and IMP works 50% leeman_s Linux - General 1 11-17-2003 10:19 PM
UW IMAP problem downloading IMAP folders nuzzy Linux - Software 1 04-17-2003 04:25 AM
IMP, IMAP, POP3, what do I need... ? ifm Linux - Software 2 08-02-2002 10:24 AM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration