Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


Search this Thread
Old 11-04-2005, 06:17 PM   #1
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 995

Rep: Reputation: 298Reputation: 298Reputation: 298
How do I toggle off fsck forcing upon boot?

Hi all, I'm using FC4 at a friend's house; he had a system crash some days ago, so I decided to run 'shutdown -Fr now' to force fsck upon next boot. The problem is I got this error when booting:

***An error has ocurred during filesystem verification
***You will be returned to a shell; the system will reboot when you exit the shell
***Warning -- SELinux is active
***Disabling security enforcement for system recovery
***Run 'setenforce 1' to reenable
Give root password for maintenance
(or type Control-D to continue):

When I press ctrl-d the system reboots and forces fsck upon boot. I tried with 'init 0' 'init 6' 'shutdown -fr now' and the system restarts with the same error. My question is, how do I toggle off the fsck forcing upon boot?? Thanks in advance.
Old 11-04-2005, 06:39 PM   #2
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,382

Rep: Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109Reputation: 1109
The system startup script that controls rebooting, e.g. /etc/rc.d/rc.sysinit, will include the logic to test to see if you want to do an fsck on reboot. It probably checks for the existence of a sentinel file in the root directory: distributions vary on this. Removing the file should eliminate the check.

On my system, man shutdown says this:
The -F flag means ‘force fsck’. This only creates an advisory file
/forcefsck which can be tested by the system when it comes up again.
The boot rc file can test if this file is present, and decide to run
fsck(1) with a special ‘force’ flag so that even properly unmounted
filesystems get checked. After that, the boot process should remove
Presumably the file is still around.
Old 11-04-2005, 09:18 PM   #3
Senior Member
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
in /etc/fstab
The 6th column (last) is a fsck option
If it's zero, fsck won't check the filesystem.
Old 11-05-2005, 10:05 AM   #4
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 995

Original Poster
Rep: Reputation: 298Reputation: 298Reputation: 298
I didn't see your replies in time, and had to reinstall . Anyway, thanks for your help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
use fsck = no boot seede Fedora 4 10-19-2005 09:34 PM
automatic fsck on boot. fsck errors. nixel Slackware 1 05-17-2004 07:51 AM
fsck on boot pjviitas Linux - General 2 02-21-2004 07:15 PM
fsck on boot pjviitas Linux - Software 1 02-21-2004 04:05 PM
forcing boot from cd nocturnal Slackware 1 11-19-2003 04:08 PM

All times are GMT -5. The time now is 07:49 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration