LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-23-2003, 05:52 AM   #1
kefen
LQ Newbie
 
Registered: Sep 2003
Location: singapore
Distribution: suse linux 9
Posts: 28

Rep: Reputation: 15
help running mplayer gui on redhat linux


i had mplayer install on my redhat linux 9, and after i copy the font and skin file into the correct directory, i try by using gmplayer and it come out as follow
CPU: Intel Pentium 4/Xeon/Celeron Northwood 1994 MHz (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf
Reading config file /home/wangjiahong/.mplayer/config
[cfg] read config file: /home/wangjiahong/.mplayer/gui.conf
Reading config file /home/wangjiahong/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/wangjiahong/.mplayer/codecs.conf: Can't open '/home/wangjiahong/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/wangjiahong/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/wangjiahong/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/wangjiahong/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).
it cannot recognise the skin file.
whatś wrong with it? i need help to make it recognise the skin file.
thanks
 
Old 10-23-2003, 06:32 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
In /usr/local/share/mplayer/Skin you need to have a skin called default.
I use the neutron skin as default, so in the Skin directory I have the neutron dir. Since I want this to be the default I simply symlink "default" to the neutron dir:
Code:
hw@baron:/usr/local/share/mplayer/Skin$ ls -l
total 4
drwxr-xr-x    2 root     staff        4096 2003-01-29 23:01 neutron/
hw@baron:/usr/local/share/mplayer/Skin$ su
Password: 
baron:/usr/local/share/mplayer/Skin# ln -s neutron/ default
baron:/usr/local/share/mplayer/Skin# ls -l
total 4
lrwxrwxrwx    1 root     staff           8 2003-10-23 12:28 default -> neutron//
drwxr-xr-x    2 root     staff        4096 2003-01-29 23:01 neutron/
baron:/usr/local/share/mplayer/Skin# exit
exit
hw@baron:/usr/local/share/mplayer/Skin$
Håkan
 
Old 10-23-2003, 06:44 AM   #3
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
When you installed, did you do it like this:
./configure

or

./configure --enable-gui

The second is the correct option for using gmplayer.

If you did it the first way, you will have to start again by issuing ./configure --enable-gui, make and (as root) make install.

You will also need to download and install the codecs.
 
Old 10-23-2003, 07:31 AM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Since mplayer is searching for the skins it should be compiled with GUI support enabled and there should be no need to do it all over again.

Håkan
 
Old 10-23-2003, 07:47 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Interestingly, and after rereading the error messages, I also received the exact same error message. I am guessing that this is the V1.0pre2 download.

It appears that mplayer isn't writing all of it's .conf files, which I think are there to tell mplayer about it's behaviour and look. (sounds like a strict teacher!)

I too would like to know how this can be fixed, I am running SuSE 9.0. I wonder if it's a bug?
 
Old 10-23-2003, 10:05 AM   #6
kefen
LQ Newbie
 
Registered: Sep 2003
Location: singapore
Distribution: suse linux 9
Posts: 28

Original Poster
Rep: Reputation: 15
thank you a lot, now i have my mplayer running perfectly and i can change the skin as i want
 
Old 10-23-2003, 02:57 PM   #7
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
Quote:
Originally posted by XavierP
I too would like to know how this can be fixed, I am running SuSE 9.0. I wonder if it's a bug?
may be for SuSE as i m running it on Slack and Mandrake without any problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Execute a program in Redhat linux as soon a when the GUI comes up alix123 Programming 5 08-15-2005 11:59 AM
Redhat Linux GUI Shortcut keys formohan Linux - Newbie 3 04-11-2005 01:37 AM
Running MPlayer from the GUI, not the command line... xbill311x Linux - Software 14 03-28-2005 10:08 PM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 11:44 AM
Linux Redhat 7.3 Hangs When Loading the GUI Login QmanV2 Red Hat 11 09-17-2003 04:59 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration