LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-24-2009, 09:23 PM   #1
tgp1994
Member
 
Registered: Nov 2009
Distribution: Used to use: Ubuntu. Still use: Debian, Other small distros
Posts: 78

Rep: Reputation: 17
Exclamation Having difficulties setting up passwd; "no matching password file entry..."


Hi there everyone. I currently have puppy linux, but I'm kind of "Debianizing" it. (Coined just now.) Basically what I have done is installed dpkg, apt-get, then I've gone on to install other packages like C++ compilers, an attempt at synaptic, and even gtk. The problem is now, lots of packages keep requiring passwd as a dependency, and when that tries to install, I pretty much get this back:

Quote:
Originally Posted by passwd
no matching password file entry in /etc/shadow
add user 'messagebus' in /etc/shadow?
If anyone can help me get around this problem so I can get passwd working once and for all, that would be great.

~TGP1994
Attached Images
File Type: jpg passwderrors.jpg (239.2 KB, 5 views)
 
Old 11-25-2009, 01:49 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 163Reputation: 163
Can you show us the output of your password and shadow file (sans encrypted passwords please?)
 
Old 11-25-2009, 02:05 PM   #3
tgp1994
Member
 
Registered: Nov 2009
Distribution: Used to use: Ubuntu. Still use: Debian, Other small distros
Posts: 78

Original Poster
Rep: Reputation: 17
Ok, here are the files:

Quote:
Originally Posted by /etc/passwd
root:x:0:0:root:/root:/bin/sh
daemon:x:1:1:daemon:/usr/sbin:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
spot:x:502:502:Linux User,,,:/root/spot:/bin/sh
bin:x:2:2:bin:/bin:/bin/sh
messagebus:x:503:503:Linux User,,,:/tmp:/bin/sh
ftp:x:1000:1000:Linux User,,,:/root/ftpd:/bin/sh
haldaemon:x:108:119:Hardware abstraction layer,,,:/var/run/hald:/bin/false
uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
webuser:x:1002:504:Linux User,,,:/root/Web-Server:/bin/sh
sys:*:3:3:sys:/dev:/bin/sh
sync:*:4:65534:sync:/bin:/bin/sync
games:*:5:60:games:/usr/games:/bin/sh
man:*:6:12:man:/var/cache/man:/bin/sh
lp:*:7:7:lp:/var/spool/lpd:/bin/sh
mail:*:8:8:mail:/var/mail:/bin/sh
news:*:9:9:news:/var/spool/news:/bin/sh
proxy:*:13:13roxy:/bin:/bin/sh
www-data:*:33:33:www-data:/var/www:/bin/sh
backup:*:34:34:backup:/var/backups:/bin/sh
list:*:38:38:Mailing List Manager:/var/list:/bin/sh
irc:*:39:39:ircd:/var/run/ircd:/bin/sh
gnats:*:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
Quote:
Originally Posted by /etc/shadow
root:$1$FD.MrIhr$BsfBOUpaBH4TPKcq0VcSk0:11329:0:99999:7:::
daemon:!:11141:0:99999:7:::
nobody:!:11141:0:99999:7:::
spot:!:12822:0:99999:7:::
bin:*:9797:0:::::
ftp:!:13885:0:99999:7:::
sshd:*:9797:0:::::
webuser:!:14442:0:99999:7:::

Last edited by tgp1994; 11-25-2009 at 02:46 PM.
 
Old 11-25-2009, 03:16 PM   #4
tgp1994
Member
 
Registered: Nov 2009
Distribution: Used to use: Ubuntu. Still use: Debian, Other small distros
Posts: 78

Original Poster
Rep: Reputation: 17
Alright, I managed to fix it by manually adding the users into the shadow file. Here's what my shadow file looked like afterwards, in case anyone else has this problem:

Quote:
root:$1$FD.MrIhr$BsfBOUpaBH4TPKcq0VcSk0:11329:0:99999:7:::
daemon:!:11141:0:99999:7:::
nobody:!:11141:0:99999:7:::
spot:!:12822:0:99999:7:::
bin:*:9797:0:::::
ftp:!:13885:0:99999:7:::
webuser:!:14442:0:99999:7:::
messagebus:!:1:0:99999:7:::
haldaemon:!:1:0:99999:7:::
uucp:!:1:0:99999:7:::
sys:*:14573:0:99999:7:::
sync:*:14573:0:99999:7:::
games:*:14573:0:99999:7:::
man:*:14573:0:99999:7:::
lp:*:14573:0:99999:7:::
mail:*:14573:0:99999:7:::
news:*:14573:0:99999:7:::
proxy:*:14573:0:99999:7:::
www-data:*:14573:0:99999:7:::
backup:*:14573:0:99999:7:::
list:*:14573:0:99999:7:::
irc:*:14573:0:99999:7:::
gnats:*:14573:0:99999:7:::
This site proved very useful for setting up the file as well.
 
  


Reply

Tags
linux, passwd, puppy


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"bad passwd file" when logging into Chroot Jail ddenton Linux - Security 3 10-17-2011 01:52 AM
the problem of "unable to lock the passwd file" greenland666 Linux - General 3 11-10-2007 09:21 AM
Turn off "Bad password" forcing in passwd Rotwang Linux - General 1 05-02-2006 08:55 AM
man file for "mount" not matching reality Melkor Slackware 15 01-10-2006 11:25 PM


All times are GMT -5. The time now is 09:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration