LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Having difficulties setting up passwd; "no matching password file entry..." (http://www.linuxquestions.org/questions/linux-software-2/having-difficulties-setting-up-passwd%3B-no-matching-password-file-entry-771355/)

tgp1994 11-24-2009 09:23 PM

Having difficulties setting up passwd; "no matching password file entry..."
 
1 Attachment(s)
Hi there everyone. I currently have puppy linux, but I'm kind of "Debianizing" it. (Coined just now.) Basically what I have done is installed dpkg, apt-get, then I've gone on to install other packages like C++ compilers, an attempt at synaptic, and even gtk. The problem is now, lots of packages keep requiring passwd as a dependency, and when that tries to install, I pretty much get this back:

Quote:

Originally Posted by passwd
no matching password file entry in /etc/shadow
add user 'messagebus' in /etc/shadow?

If anyone can help me get around this problem so I can get passwd working once and for all, that would be great.

~TGP1994

rweaver 11-25-2009 01:49 PM

Can you show us the output of your password and shadow file (sans encrypted passwords please?)

tgp1994 11-25-2009 02:05 PM

Ok, here are the files:

Quote:

Originally Posted by /etc/passwd
root:x:0:0:root:/root:/bin/sh
daemon:x:1:1:daemon:/usr/sbin:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
spot:x:502:502:Linux User,,,:/root/spot:/bin/sh
bin:x:2:2:bin:/bin:/bin/sh
messagebus:x:503:503:Linux User,,,:/tmp:/bin/sh
ftp:x:1000:1000:Linux User,,,:/root/ftpd:/bin/sh
haldaemon:x:108:119:Hardware abstraction layer,,,:/var/run/hald:/bin/false
uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
webuser:x:1002:504:Linux User,,,:/root/Web-Server:/bin/sh
sys:*:3:3:sys:/dev:/bin/sh
sync:*:4:65534:sync:/bin:/bin/sync
games:*:5:60:games:/usr/games:/bin/sh
man:*:6:12:man:/var/cache/man:/bin/sh
lp:*:7:7:lp:/var/spool/lpd:/bin/sh
mail:*:8:8:mail:/var/mail:/bin/sh
news:*:9:9:news:/var/spool/news:/bin/sh
proxy:*:13:13:proxy:/bin:/bin/sh
www-data:*:33:33:www-data:/var/www:/bin/sh
backup:*:34:34:backup:/var/backups:/bin/sh
list:*:38:38:Mailing List Manager:/var/list:/bin/sh
irc:*:39:39:ircd:/var/run/ircd:/bin/sh
gnats:*:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh

Quote:

Originally Posted by /etc/shadow
root:$1$FD.MrIhr$BsfBOUpaBH4TPKcq0VcSk0:11329:0:99999:7:::
daemon:!:11141:0:99999:7:::
nobody:!:11141:0:99999:7:::
spot:!:12822:0:99999:7:::
bin:*:9797:0:::::
ftp:!:13885:0:99999:7:::
sshd:*:9797:0:::::
webuser:!:14442:0:99999:7:::


tgp1994 11-25-2009 03:16 PM

Alright, I managed to fix it by manually adding the users into the shadow file. Here's what my shadow file looked like afterwards, in case anyone else has this problem:

Quote:

root:$1$FD.MrIhr$BsfBOUpaBH4TPKcq0VcSk0:11329:0:99999:7:::
daemon:!:11141:0:99999:7:::
nobody:!:11141:0:99999:7:::
spot:!:12822:0:99999:7:::
bin:*:9797:0:::::
ftp:!:13885:0:99999:7:::
webuser:!:14442:0:99999:7:::
messagebus:!:1:0:99999:7:::
haldaemon:!:1:0:99999:7:::
uucp:!:1:0:99999:7:::
sys:*:14573:0:99999:7:::
sync:*:14573:0:99999:7:::
games:*:14573:0:99999:7:::
man:*:14573:0:99999:7:::
lp:*:14573:0:99999:7:::
mail:*:14573:0:99999:7:::
news:*:14573:0:99999:7:::
proxy:*:14573:0:99999:7:::
www-data:*:14573:0:99999:7:::
backup:*:14573:0:99999:7:::
list:*:14573:0:99999:7:::
irc:*:14573:0:99999:7:::
gnats:*:14573:0:99999:7:::
This site proved very useful for setting up the file as well.


All times are GMT -5. The time now is 11:49 AM.