LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-13-2003, 12:54 PM   #1
underling
LQ Newbie
 
Registered: Sep 2003
Location: Scotland
Distribution: Redhat 9
Posts: 24

Rep: Reputation: 15
Gnome theme problems


Having a problem getting themes to work in Gnome. Been using KDE for a while but decided to use Gnome as I have heard it can be faster. Anyway. All icons are the basic 'file icon' and whenever I try to enter preferences>theme I get this error -

"The default theme schemas could not be found on. This means that you probably don't have metacity installed, or that your gconf is configured incorrectly."

I've searched around and found a few solutions that people have used to fix it but none worked for me.

Using Redhat 9 (2.4.20-8) and whatever gnome ships as standard with that.

Any ideas?
 
Old 10-14-2003, 06:55 AM   #2
jimieee
Member
 
Registered: Aug 2003
Location: London, UK
Distribution: Debian and Fedora for play and RHEL + Solaris for work
Posts: 172

Rep: Reputation: 15
I also have RH9 running Gnome, but my themes work. I know this is a bit of a basic suggestion, but have you tried doing rpm -qa | grep meta to find out if metacity is installed. Is something like metacity-2.4.34-3 listed? If not then just get the rpm from RH or your install source or somewhere.

If not then I'd start again or spend ages trawling through google to figure it out.
 
Old 10-14-2003, 09:17 AM   #3
underling
LQ Newbie
 
Registered: Sep 2003
Location: Scotland
Distribution: Redhat 9
Posts: 24

Original Poster
Rep: Reputation: 15
Hi. Yeah. Metacity is installed. Actually got the problem fixed last night. No idea how though. I was making some adjustments to XF86Config-4 file and restarting X and all of a sudden it just worked.

Thanks for the suggestion anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome 2.8 theme problems mrsolo Linux - Software 1 09-21-2004 10:37 AM
Upgrade to Gnome 2.6 theme problems QCompson Linux - Software 0 06-20-2004 10:39 AM
Problem getting installed GNOME theme to show in theme list on RedHat 9.0 linux-fan64 Linux - Newbie 1 02-25-2004 06:16 PM
Gnome theme problems -- buttons, sliders, etc. Jiawen Linux - General 4 12-09-2003 12:04 PM
Gnome Theme rch Linux - Software 2 05-03-2003 11:36 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration