LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-10-2004, 11:02 PM   #1
Sephiroth
LQ Newbie
 
Registered: Feb 2004
Distribution: Slackware 10.1
Posts: 24

Rep: Reputation: 15
giFTcurs cant find right version of glib


im trying to install giFTcurs on redhat 7.2. ive installed glib version 2.0.0 but the configuration cant seem to be able to find it. i have already set the PKG_CONFIG_PATH to the folder where glib-2.0.pc is, but this has only resulted in it finding the previous distribution of glib and giving me an error message that configuration is finding the wrong version of glib. i cant uninstall the previous version of glib because it has too many dependencies.

the error message i am getting is

Quote:
the test program compiled, but did not run. This usually means that the run-time linker is not finding GLIB or finding the wrong version of GLIB. If it is not finding GLIB, you'll need to set your LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point to the installed location. If you have an old version installed, it is best to remove it, although you may also be able to get things to work by modifying LD_LIBRARY_PATH. configure:error:You need glib-2.0 to compile giFTcurs
i am pretty sure the program is finding glib, since the error message is different from the one i was getting before i set my PKG_CONFIG_PATH. but what do i need to do to the LD_LIBRARY_PATH variable to make it point to glib-2.0.pc instead of glib.pc?

any help would be greatly appreciated
 
Old 02-11-2004, 02:18 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Have a look at glib.pc to see if it's not a symlink. An ls -l glib* in the appropriate directory will show you this. If it is a symlink then delete it and link it to glib-2.0.pc. You may need to link it back to the old one later if you get dependency problems running apps that used to run but no longer do.

An even better solution is to get apt4rpm. It's a dependency solver and will allow you to upgrade packages (like glib, for example) with a minimum of fuss. It's available here.
 
Old 02-11-2004, 08:40 PM   #3
Sephiroth
LQ Newbie
 
Registered: Feb 2004
Distribution: Slackware 10.1
Posts: 24

Original Poster
Rep: Reputation: 15
apt4rpm needs librpm.so.0. i did a search and couldnt find it. what exactly is this and where can i get it?

thanks
 
Old 02-11-2004, 09:33 PM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
This is exactly why I can't stand rpm-based distros. What you need is the librpm package. Have a look at www.rpmseek.com and type "librpm" into the search engine. Hopefully, you wont need too many other dependencies to install this.

Last edited by adz; 02-11-2004 at 09:34 PM.
 
Old 02-11-2004, 09:38 PM   #5
Sephiroth
LQ Newbie
 
Registered: Feb 2004
Distribution: Slackware 10.1
Posts: 24

Original Poster
Rep: Reputation: 15
my existing rpm package when queried with rpm -q rpm returns rpm-4.0.3-1.03. ive read that more recent versions of apt4rpm does support this, but i cant seem to find what version does. any ideas?
 
Old 02-11-2004, 09:48 PM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Once again, I don't use rpm-based distros so I don't know. I've never used apt4rpm myself. I use apt since it comes standard with debian (a fact for which I'm eternally grateful) and was the basis on which apt4rpm was founded on. I've compiled giFT on debian many times and have had no major problems. Apparently it's even easier to do on gentoo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
Issues with glib, "cannot find glib".. Mandrake 10.1... Please Help!~ TheCowboy Mandriva 2 03-01-2005 05:49 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
GLIB error while installing giFTcurs Mehul_Sangani Linux - Software 3 09-27-2003 01:18 PM
giFTcurs requires gLib.. do I have it? whoistom Linux - Software 20 09-17-2003 05:16 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration