LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-28-2004, 12:03 AM   #1
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Rep: Reputation: 15
Getting Mplayer to work...... Help!


Hi all I'm having problems getting Mplayer to work. Here's what I have done to this point.

I downloaded Mplayer-0.92.tar.bz2, I unpacked it, changed to that directory, and then configured the source with ./configure --enable-gui. That all went well. I then compiled with the make command. That all seemed to go well, I didn't have any errors. I then switched to become root and installed Mplayer with make install. It installed fine, no errors.

Now at this point I don't have any skins or fonts. So I downloaded fonts and one skin, I think it's the default, but not sure. I unpack them to /usr/local/share/mplayer/skin and /usr/local/share/mplayer/font. Now here's my problem. I can't seems to get the gui to work and get it to work in the terminal. I'm thinking to much like windows, having been using Linux for just about a month now. BTW I'm using Suse 9.0. What directory is the executable stored? I've heard something about the config file for Mplayer, do I need to set it up or something?

It seems like there are bits of Mplayer everywhere in the root directory. is this normal for programs to do this? Any help would be great.

Thanks,
chevy
 
Old 03-28-2004, 12:23 AM   #2
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
The command for mplayer is "mplayer", but the graphical one is gmplayer and not just mplayer. I hope this helps.
 
Old 03-28-2004, 12:34 AM   #3
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Original Poster
Rep: Reputation: 15
Ok, this is what I get when i type gmplayer in the terminal:


steve@linux:~> gmplayer
MPlayer 0.92-3.3.1 (C) 2000-2003 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/steve/.mplayer/config
[cfg] read config file: /home/steve/.mplayer/gui.conf
Reading config file /home/steve/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
Reading /home/steve/.mplayer/codecs.conf: can't open '/home/steve/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/steve/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/steve/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/steve/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).
steve@linux:~>


What do I need to do to get it to work?


Chevy
 
Old 03-28-2004, 02:24 AM   #4
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
I have no idea because it my the directories for me when I ran it. I found a tutorial on it before, but I'm not sure where it is anymore because I only used it to find out where the skins directory was.
 
Old 03-28-2004, 10:46 AM   #5
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
Ok, you have to dowload a skin and rename the skin to default. Then move the skin to /home/<usrname>/.mplayer/Skin then you can run the command gmplayer. Mplayer doesn't come with any skins, so you have to go to the site to download one.
 
Old 03-28-2004, 10:49 AM   #6
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
It might also be a good idea to stick the skin in /usr/share/mplayer/Skin and call it default so it will work for all users. I didn't know this because when I emerged it in Gentoo, I was given the blue skin as default.
 
Old 03-28-2004, 01:26 PM   #7
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Original Poster
Rep: Reputation: 15
Ok here's what I have done now. I renamed the skin I downloaded to "default" and put it in /usr/local/share/mplayer/Skin. Now when I run gmaplyer in terminal this what i get:

steve@linux:~> gmplayer
MPlayer 0.92-3.3.1 (C) 2000-2003 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/steve/.mplayer/config
[cfg] read config file: /home/steve/.mplayer/gui.conf
Reading config file /home/steve/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
Reading /home/steve/.mplayer/codecs.conf: can't open '/home/steve/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /home/steve/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/steve/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/steve/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.

Exiting... (Exit)
steve@linux:~>

Now it looks like to me that my font is not correct or setup right. Where do the fonts need to go so mplayer will work?

Thanks alot so far,
Chevy
 
Old 03-28-2004, 02:04 PM   #8
gabebster
Member
 
Registered: Jun 2003
Location: Oklahoma
Distribution: Gentoo
Posts: 117

Rep: Reputation: 15
In the /usr/local/share/mplayer/font directory put the contents of one of the fonts that you downloaded into that directory.

Code:
gabvav@linux:/usr/local/share/mplayer/font> ls 
font.desc iso-8859-1-b.raw   osd-mplayer-b.raw
iso-8859-1-a.raw  osd-mplayer-a.raw 
gabvav@linux:/usr/local/share/mplayer/font>
 
Old 03-28-2004, 05:11 PM   #9
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Rep: Reputation: 15
When I compiled mplayer I had to use the following flag to make the gui work "--enable-gui". After this I had no problems starting mplayer using the command "gmplayer" under gnome. For the fonts I unpacked them in /usr/local/share/mplayer/font. Now if I only had a faster cpu I could watch my dvd's like I could on my dvd player
 
Old 03-28-2004, 07:00 PM   #10
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Original Poster
Rep: Reputation: 15
Ok, I now have only one font in /usr/local/share/mplayer/font , just the font no folder with the font in it. It works now!! WooHoo!

Now to get it to work I have to type gmplayer in a terminal. What I would like to do is have an Icon to click on instead of typing. How would I go about doing that? Is it possible?

I also want to thank all who giving me a push in the right direction

Cheers,
chevy
 
Old 03-29-2004, 02:15 AM   #11
gabebster
Member
 
Registered: Jun 2003
Location: Oklahoma
Distribution: Gentoo
Posts: 117

Rep: Reputation: 15
Just right click on the desktop and at the "Create New" sub menu go to "Link to Application..." and then at under the execute tab put "gmplayer". The mplayer icon can be found in your skin directory under icons. This is if your using kde and not gnome. I don't know how to do it in gnome cause i don't use it.

gabebster

Last edited by gabebster; 03-29-2004 at 02:16 AM.
 
Old 03-29-2004, 06:50 AM   #12
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks alot, but I was wondering ...where do I find the ...like .exe or link to launch the app? I was able t find the icon and created the link.

Thanks,
Chevy
 
Old 03-29-2004, 03:05 PM   #13
gabebster
Member
 
Registered: Jun 2003
Location: Oklahoma
Distribution: Gentoo
Posts: 117

Rep: Reputation: 15
The "exe" for gmplayer is in /usr/local/bin.

gabebster
 
Old 03-29-2004, 04:28 PM   #14
chevy2410
Member
 
Registered: Jan 2004
Distribution: suSE
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks for all the help. I miss read your last post. You said to just type gmplayer into the execute tab and I thought it said something else for whatever reason.

I did that and now the link works and the whole program works!!

One other thing I would like to know is when I have a .avi or a divx or wma....whatever ... how do I set mplayer to be the default player for these types of files? Basically I want to be able to click on the file and have mplayer play it not Noatun.

Thanks,
Chevy
 
Old 03-29-2004, 04:35 PM   #15
dizzy_vee
LQ Newbie
 
Registered: Mar 2004
Distribution: SuSE 9, Mandrake 10
Posts: 19

Rep: Reputation: 0
If you're using KDE, then right click on a file of the type you want to change (i.e. if you want to associate .avi files with Mplayer, right click on an .avi file), and choose Edit file type...

In the windows that pops up, you should see the application preference listed at the bottom... click on mplayer, and then click on Move up until it's at the top. If mplayer is not there, then click Add and add it from the window that pops up.

Cheers,
Dizzy V.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer won't work w/FF 1.0.6 raysr Mandriva 2 08-23-2005 07:26 PM
Can't get Mplayer to work n17man Linux - Software 1 02-21-2005 12:10 PM
mplayer don't work shams Fedora 0 12-16-2004 08:16 PM
getting mplayer to work RIgimp75 Slackware 10 01-25-2004 05:12 PM
Mplayer - how do I get it to work?? drfresh Linux - Newbie 4 06-25-2003 11:52 AM


All times are GMT -5. The time now is 01:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration