LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2003, 03:47 AM   #1
JsCAMRY
Member
 
Registered: Oct 2003
Location: Oviedo,FL
Posts: 46

Rep: Reputation: 15
Gedit


hey all hows it going? I am new to linux, Redhat 9. I am trying to mount my slave hdd. I am following the redhat guide on redhat's site redhat.com/docs/manuals/linux/(i was not able to link to a website since I do not have posted enough yet.) I have followed the guide up until the Gedit. when i open FStab in Gedit, I am not able to edit or modify the file, since is a read-only file. Also when I tried to mount the hdd in a terminal I recieved this message

[root@localhost etc]# /dev/hda1 /mnt/windows vfat umask=000,defaults 0 0
bash: /dev/hda1: Permission denied

Thanks all, I am really trying to learn how to use linux, its fun; just takes some time.

J.
 
Old 11-05-2003, 03:52 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
You need to run gedit as root to make changes to fstab. Or in any editor - it's not a gedit problem. Once you've made the changes, you should be able to mount it with 'mnt /mnt/windows'.
 
Old 11-05-2003, 04:03 AM   #3
JsCAMRY
Member
 
Registered: Oct 2003
Location: Oviedo,FL
Posts: 46

Original Poster
Rep: Reputation: 15
how do I run Gedit as root? Is this done in a terminal? do I have to use the "su" command or something?

also is there anyway to make my monitor shut off after a certain amount of time has elasped?

thanks for the help

J.

Last edited by JsCAMRY; 11-05-2003 at 04:06 AM.
 
Old 11-05-2003, 05:02 AM   #4
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
open your terminal do a su to gain root permissions then just type gedit /etc/fstab and it shoudl show you the file then edit it and save it to just run gedit as root perform gedit without /etc/fstab

for your monitor use xscreensaver ...

btw man is a great tool for finding answears :=)
 
Old 11-05-2003, 05:05 AM   #5
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Yep - you got it. I mean, there's various ways, but 'su' in a terminal and typing 'gedit' into it is the most direct route.

In Slackware, in /etc/rc.d/rc.m there's the line
/bin/setterm -blank 15
I guess there's something similar in a similar script for RH.
 
Old 11-05-2003, 05:58 AM   #6
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
yeah he could also use some text editor i like nano a lot for example but i dont think its the right thing for him at the moment so he better stayes with gedit so far
 
Old 11-06-2003, 03:38 AM   #7
JsCAMRY
Member
 
Registered: Oct 2003
Location: Oviedo,FL
Posts: 46

Original Poster
Rep: Reputation: 15
first, I would like to thank you all for you help. second I was able to open the gedit /etc/fstab file. but when i went to edit the file by adding /dev/hda1 /mnt/windows vfat auto,umask=0 0 0 to another line. I recieved this error message "Unable to make a backup of the original file." So I was not able to save the file.

thanks Jason
 
Old 11-06-2003, 03:47 AM   #8
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
You got that running gedit as root? And you tried another editor and got the same message? The only reason I could think of for that message is that your root partition is slam full (extremely unlikely) or that you don't have permission to write to /etc (which root does) or something's buggy with your gedit (which seems odd and would be likely ruled out if the same thing happened in another editor). The last thing I can think of is that your whole root filesystem is mounted read-only (again, extremely unlikely).

Maybe somebody else has an idea but, if you are root, it happens in other editors, etc., etc. - I'm stumped.

Which RH manual are you following? I went to the page but it's a list of several manuals.
 
Old 11-06-2003, 03:55 AM   #9
JsCAMRY
Member
 
Registered: Oct 2003
Location: Oviedo,FL
Posts: 46

Original Poster
Rep: Reputation: 15
Yes I was in root when I was in the terminal and tryped su, then I typed gedit /etc/fstab and the gedit opened then I typed in "/dev/hda1 /mnt/windows vfat auto,umask=0 0 0" on a new line. I am not sure if I was in root while I was using gedit. I am using the RH manual

thanks jason
 
Old 11-06-2003, 04:12 AM   #10
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, it doesn't matter which directory you open gedit from. Kinda confusing - the fact that '/' is the 'root' filesystem and contains a directory called 'root' that is the home of the user 'root'. You just need to be the user 'root' when launching the app and opening, editing, and saving the file.

Hm. I just fired up gedit and edited fstab with it. No problem. But try edit>preferences>editor>save and unchecking 'backup' for the heck of it. You tried another editor? Like I say, I'm stumped. I don't even know what sort of diagnostics to get you to try beyond what I said above. Hope somebody gets you sorted out.
 
Old 11-06-2003, 02:54 PM   #11
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
Quote:
Originally posted by JsCAMRY
Yes I was in root when I was in the terminal and tryped su, then I typed gedit /etc/fstab and the gedit opened then I typed in "/dev/hda1 /mnt/windows vfat auto,umask=0 0 0" on a new line. I am not sure if I was in root while I was using gedit. I am using the RH manual

thanks jason
you forgot the last two 0 s :=)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gedit very slow janux Linux - Software 6 11-07-2005 03:54 PM
problems with gedit hitlaur Linux - Newbie 4 11-09-2004 11:16 PM
Can't update Gedit rvoigt Linux - Newbie 1 09-28-2004 07:15 AM
gedit-like app? Smokey Slackware 9 07-19-2004 11:21 AM
how can i reinstall gedit? vree13 Linux - Newbie 5 03-05-2004 05:17 PM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration