LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-05-2003, 04:43 AM   #1
lamekain
LQ Newbie
 
Registered: Apr 2003
Location: Finland
Distribution: Mandrake 9.1
Posts: 14

Rep: Reputation: 0
Unhappy GDM changing permission of Garnome-script


Hey,

I have the following problem: I installed Gnome2.4 desktop via Garnome and got it up and running, but everytime I boot my machine something changes the Garnome exec-script I have in X11/gmd/Sessions into non-executable. So everytime I want to start Garnome after boot, I have to log in as root and change the file into an executable.. efficient, huh?
I can't figure what changes the file, but I got these from syslogs:

gdmgreeter[1743]: Wrong permissions on /etc/X11/gdm/Sessions//Garnome. Should be readable/executable for all.
gconfd (abuser-2048): Resolved address "xml:readonly:/usr/share/garnome/etc/gconf/gconf.xml.mandatory" to a read-only config source at position 0
gconfd (abuser-2048): Resolved address "xml:readonly:/usr/share/garnome/etc/gconf/gconf.xml.defaults" to a read-only config source at position 2 !

What do I have to do to make the script stay x for all?? Help wanted and needed..
 
Old 11-05-2003, 07:26 AM   #2
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
cd to the dir where the files are and type:

#chmod +xw file_name #for making things Writable and eXecutable or:

#chmos -xw file_name #for making things readonly. type:
#ls -l #thats LS -L (only lower case)

it will print to the screen a list of the files and (among other things the permissions of the files)

Is this what you are after?
 
Old 11-05-2003, 11:32 AM   #3
lamekain
LQ Newbie
 
Registered: Apr 2003
Location: Finland
Distribution: Mandrake 9.1
Posts: 14

Original Poster
Rep: Reputation: 0
I've done that many times and it works. But everytime I boot the machine something changes the file from -wxr-xr-x into -rw-r--r-- . So everytime I want to start the Garnome-script after boot I first have to log in as root and change it into an executable, and then log out and log in with my standard user...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Garnome to be in the GDM menu, mandrake 10 - NEWBIE d3viant Mandriva 5 10-19-2004 05:23 PM
Changing default gui from gdm to kdm mecister Linux - Newbie 1 06-23-2004 02:27 PM
GDM Greeter - changing error messages Rom@n Linux - Software 0 03-02-2004 11:52 PM
how to garnome using gdm justmedric Fedora 1 01-08-2004 03:48 PM
changing GDM, xinit, etc. contrasutra Linux - Software 2 04-27-2003 10:53 PM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration