LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-30-2006, 01:43 PM   #1
crazyjimbo
Member
 
Registered: Mar 2006
Location: Edinburgh
Distribution: Debian Etch, Gentoo
Posts: 90

Rep: Reputation: 16
Everything in Beryl is white


I'm sorry it has come to asking here, I don't feel right asking for help with something that, by its very nature, is unstable.

But anyway, the problem is that, having installed Beryl, it loads ok, but everything it displays is white (and I mean everything!). At first I thought it was just gving me a completely white screen, but it turns out I can spin the cube, even move windows, but everything is just white so I can't see it. This seems to be a reasonably common problem as there were a lot of pages show up when I googled, but no one has definate solution.

I get the same results using either Xgl or the regular X server, the stable or the beta Nvidia drivers and Gentoo or Debian (I haven't tried every possible combination). My Graphics card is an Nvidia 7600GS in a twinview configuration.

If anyone has any suggestions, I'd be most grateful,

Thank You,
James
 
Old 11-30-2006, 04:51 PM   #2
cybertaz
Member
 
Registered: Oct 2006
Distribution: SuSE 11.0
Posts: 118

Rep: Reputation: 15
I had the same thing. Re-install the nvidia driver. On the last step where it asks you if you want the installer to change the xorg.conf file SAY NO! That is all I had to do to get it working.

EDIT:I'm using the latest drivers from nvidia
 
Old 02-04-2007, 02:32 PM   #3
lookin@linux
LQ Newbie
 
Registered: Apr 2006
Posts: 6

Rep: Reputation: 0
Running SuSE 10.2 & Beryl
Hate to revive an old message but im getting this same problem. Beryl was working famously last night, but this morning, all went to hell. I tried what was stated above but it didnt work. I have also found numerous people telling me what to do in case this occurs but what they tell me to do wont work! I might be doing it wrong though...

They Say:
"
Type this:
~> kate $HOME/.beryl-managerrc2

copy/paste this:


[wm-settings]
active_wm=0
fallback_wm=0
active_dm=0
iconsize=24
use_fallback_wm=true

[beryl-settings]
render_path=0
cow_mode=0
rendering_mode=0
platform=0
binding=0
no_gl_yield=false

save, then:

~> kate $HOME/.kde/Autostart/beryl.sh

copy/paste this:

cp -T $HOME/.beryl-managerrc2 $HOME/.beryl-managerrc
beryl-manager
"
Before, when it logged in, it would show the beryl logo then just the white screen. The only way i thought of doing anything was by pressing ctrl alt f1. It doesnt allow me to do the Kate command. How would i do it? Now, after i reinstalled my nvidia drivers, it doesnt even take me to the desktop or the white screen. It just tells me to textually login. I log in and type startx but it says:

"Fatal server error:
Could not create server lock file: /tmp/x0-lock
giving up.
xinit: Connection refused (errno 111): unable to connect to x server
xinit: No such process (errno 3): Server Error."

Any suggestions? Should do a repair install or something and redo everything? Would doing a repair off the suse disk basically revert to "factory" settings and files?

Thanks!
 
Old 02-15-2007, 07:48 AM   #4
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
It happens to me occasionally too; in order to restore proper function, I switch to console, kill beryl and any gnome-decorators, switch back to X and start beryl from the beryl-manager window manager menu. When you are in console and want to run an X application, you need to type
Code:
export DISPLAY=:0.0
and then beryl-manager or whatever else you want.
 
Old 02-16-2007, 12:48 AM   #5
Phil459
LQ Newbie
 
Registered: Dec 2006
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by auxsvr
It happens to me occasionally too; in order to restore proper function, I switch to console, kill beryl and any gnome-decorators
How is this accomplished? When I switch to console and type kill beryl it tells me that the kill command needs a process number?
 
Old 02-17-2007, 08:50 AM   #6
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
You can kill beryl with one of the following:
Code:
killall beryl-xgl
or
Code:
kill `pidof beryl-xgl`
.
 
Old 02-17-2007, 11:54 PM   #7
Phil459
LQ Newbie
 
Registered: Dec 2006
Posts: 15

Rep: Reputation: 0
Thanks, at least I can get to my desktop now.
 
Old 02-18-2007, 02:06 AM   #8
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
Or use 'beryl --use-copy' when launching. This is attributed to a problem with GLX_texture_from_pixmap. Update drivers to the latest Nvidia drivers and also update your Xorg to 7.2. Xorg 7.2 RC2 has lots of bugs.
 
Old 02-18-2007, 07:59 AM   #9
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
When I reach the desktop, I run beryl-manager and select beryl as the window manager (or reload it). Then everything works quite well, at least until next reboot.
 
Old 03-02-2007, 01:10 AM   #10
51dunk
Member
 
Registered: Jan 2007
Distribution: Slackware 11, OpenSuse 10.2
Posts: 31

Rep: Reputation: 15
I gotta to re-up this post.
I have the same problem as the thread starter, and i can't solve it yet.

Environment: graphic card : Nvidia 6600 (driver 96.31)
beryl : svn packages (0.2.0)

Could someone tell me that is this a problem of my graphic card or beryl svn bug?
I can run beryl-manager successfully after login as root.
So i think the white cube problem of my user account might be that i put "beryl" and "beryl-manager" into the startup-session list.
So could anyone tell me that what can i do to enter the Desktop using user account after white cube and then i can go to fix startup-session list.
 
Old 03-02-2007, 02:33 AM   #11
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
Exclamation

Hi,

in beryl settings manager, there's an option "sync to vblank" in the general options tab. Make sure that it's unchecked (disabled).
 
Old 03-02-2007, 03:25 AM   #12
51dunk
Member
 
Registered: Jan 2007
Distribution: Slackware 11, OpenSuse 10.2
Posts: 31

Rep: Reputation: 15
Quote:
Originally Posted by almatic
Hi,

in beryl settings manager, there's an option "sync to vblank" in the general options tab. Make sure that it's unchecked (disabled).

Excuse me, are you said to me?

If is, that I can't get to my user desktop, so i couldn't change any GUI settings.
I wonder if it has some command.
 
Old 03-02-2007, 03:31 AM   #13
Brianetta
LQ Newbie
 
Registered: Mar 2007
Location: Newcastle upon Tyne, UK
Distribution: Trustix, Fedora, Ubuntu
Posts: 16

Rep: Reputation: 3
Quote:
Originally Posted by 51dunk
Could someone tell me that is this a problem of my graphic card or beryl svn bug?
Since I get the exact same effect on my ATI Radeon 9800 Pro (a white cube, although interestingly enough the drop shadows are just visible if I manage to open a window) I would say it's more likely to be a problem with Beryl than a problem with your nVidia card. Compiz never exhibits this problem either.
 
Old 03-02-2007, 03:53 AM   #14
51dunk
Member
 
Registered: Jan 2007
Distribution: Slackware 11, OpenSuse 10.2
Posts: 31

Rep: Reputation: 15
Quote:
Originally Posted by Brianetta
Since I get the exact same effect on my ATI Radeon 9800 Pro (a white cube, although interestingly enough the drop shadows are just visible if I manage to open a window) I would say it's more likely to be a problem with Beryl than a problem with your nVidia card. Compiz never exhibits this problem either.

yes, that might be beryl's but, so did solve this white cube problem?
if yes, how did you do?I really have no idea recently, i tried many ways.
 
Old 03-02-2007, 04:12 AM   #15
Brianetta
LQ Newbie
 
Registered: Mar 2007
Location: Newcastle upon Tyne, UK
Distribution: Trustix, Fedora, Ubuntu
Posts: 16

Rep: Reputation: 3
No, no solution. I used compiz instead.
 
  


Reply

Tags
beryl, kate, nvidia, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard shortcuts in Beryl shame Suse/Novell 1 03-23-2007 08:14 AM
edgy + beryl random guy Linux - Software 2 11-30-2006 10:08 PM
Beryl have arrived to Debian ! megaprog Debian 22 11-30-2006 07:57 AM
Trying to use beryl/aiglx, but it won't boot. kbutcher5 Arch 6 11-24-2006 04:45 PM
xgl beryl tv out broken nvidia cjae Linux - Software 3 10-26-2006 12:39 AM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration