LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-13-2003, 12:57 PM   #1
dwof
LQ Newbie
 
Registered: Mar 2002
Location: Wageningen, The Netherlands
Distribution: RedHat 7.3 and 9.0
Posts: 13

Rep: Reputation: 0
Question error with mounting samba share on linux as normal user


Hi people,

I get an error when I try to mount a share from my red-hat 7.3 samba server on my red-hat 9 box.
When I type

¨mount -t smbfs //this.ip.samba.server/sharename /mnt/mnt1 -o user-name=bladiebla,password=somethingelse¨

and I use the root user-name and password, the share gets mounted just fine. If I use another users credentials though, it will not moun. It gives the following error:

6301: tree connect failed: ERRDOS - ERRnosuchshare (You specified an invalid share name)
SMB connection failed

If I type

smbclient -L this.ip.samba.server -U username

and use the user-name I used when trying to mount the share, it is listed. So the share exists, I see it when giving smbclient -L..... and still it will only mount when mounted with the root credential. I do not understand why it will not mount.

I hope someone can help me. Thanks,

Dolf.
 
Old 08-13-2003, 01:10 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
I thinkthat the -o option has to be before the sharename.
mount -t smbfs -o user-name=bladiebla,password=somethingelse¬ //this.ip.samba.server/sharename /mnt/mnt1
 
Old 08-13-2003, 01:17 PM   #3
dwof
LQ Newbie
 
Registered: Mar 2002
Location: Wageningen, The Netherlands
Distribution: RedHat 7.3 and 9.0
Posts: 13

Original Poster
Rep: Reputation: 0
Nope that's not the problem. It does exactely the same with your order. It also does the same when I use smbmount instead of mount -t smbfs

Cheers,

Dolf.
 
Old 08-13-2003, 01:22 PM   #4
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
I should have seen this. user-name needs to be username.
 
Old 08-13-2003, 01:28 PM   #5
dwof
LQ Newbie
 
Registered: Mar 2002
Location: Wageningen, The Netherlands
Distribution: RedHat 7.3 and 9.0
Posts: 13

Original Poster
Rep: Reputation: 0
nope that's not the problem either. It is something more complicated I think. there are no spaces, dashes, etc in the usernames. the only difference between the mounting going right and wrong is that with the one that works I use

-o username=root,password=****** and the other one is
-o username=somename,password=******

That's is the only difference between working and not working.
 
Old 08-13-2003, 03:21 PM   #6
Electric_Blue
Member
 
Registered: Aug 2003
Distribution: RedHat
Posts: 35

Rep: Reputation: 15
I get that message when my user does not have connect rights to the share. Also I "think" when the directory does not have access rights for the user or group.

Is the user set up on both of the linux boxes?

I'm assuming this is a share you have set up in the share definitions of the smb.conf file and the valid users include your user.
 
Old 08-13-2003, 03:53 PM   #7
dwof
LQ Newbie
 
Registered: Mar 2002
Location: Wageningen, The Netherlands
Distribution: RedHat 7.3 and 9.0
Posts: 13

Original Poster
Rep: Reputation: 0
In both the server and the client the user admin exists, both in the same administrator group. The directory on the server is owned by admin:administrator and the folder where I want to mount the share on the client is owned by admin:administrator too. The share has admin and @administrator in the valid users list. Part of my smb.conf is online at http://smokeyd.homelinux.com/tmp/smb.conf.txt
It includes my Global settings and the settings for the share. I also defined the admin user in the smbpasswd. I would get a different error if it wasn't defined or the password was wrong.

Thnx,

Dolf.

Last edited by dwof; 08-13-2003 at 04:52 PM.
 
Old 08-13-2003, 04:57 PM   #8
Electric_Blue
Member
 
Registered: Aug 2003
Distribution: RedHat
Posts: 35

Rep: Reputation: 15
Quote:
-o username=root,password=****** and the other one is
-o username=somename,password=******

That's is the only difference between working and not working.
Yea you're right.

The only time I got that error was when the actual mount point or share point truly did not exist. If the user didn't have rights to the share you get the no access message first, regardless of the share point's validity.

very weird

BUT that was to an NT share, I don't have another linux box running samba to play with at the moment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba OS X to Linux Samba file share error ttoomey Linux - Software 1 08-16-2005 10:12 AM
mounting problems as normal user wisdom Linux - Networking 1 01-19-2005 10:26 AM
Mounting pendrive as a normal user (non-root) hbarbosa Linux - Hardware 1 11-03-2003 02:20 PM
Error mounting Samba Share cmfarley19 Linux - Software 2 08-22-2003 12:56 PM
Mounting ISO files as a normal user... Thymox Linux - General 3 02-16-2002 10:32 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration