LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 06-07-2007, 07:32 PM   #1
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 21
Posts: 359

Rep: Reputation: 30
Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib etc...


Okay, I was trying to update to Fedora 7 and got a bunch of errors.

I did the following a bunch of times:

Code:
# yum clean all
# yum update
# yum -y update
# rpm --rebuilddb
I still am getting the following:

Code:
--> Finished Dependency Resolution
Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib
Error: Missing Dependency: python-optik is needed by package up2date
Error: Missing Dependency: python(abi) = 2.4 is needed by package up2date
Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package pidgin
This occurs when doing yum update and yum -y update. What's going on and how do I fix it?

Thanks.
 
Old 06-07-2007, 11:24 PM   #2
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 21
Posts: 359

Original Poster
Rep: Reputation: 30
Nobody knows?

I have had no success with searching for an answer.

Code:
# yum install python24-optik
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
fedora                    100% |=========================| 2.1 kB    00:00     
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do
 
Old 06-08-2007, 09:02 AM   #3
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 21
Posts: 359

Original Poster
Rep: Reputation: 30
bump for desperate times
 
Old 06-08-2007, 05:07 PM   #4
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 21
Posts: 359

Original Poster
Rep: Reputation: 30
Okay, I deleted up2date/rhnlib and removed pidgin and reinstalled. Things look better.

Glad I entertained you all.
 
Old 10-31-2007, 09:50 AM   #5
multitude
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
same problem here

Quote:
Originally Posted by punt View Post
Okay, I deleted up2date/rhnlib and removed pidgin and reinstalled. Things look better.

Glad I entertained you all.
I just had the same problem updating Fedora 7. Errors were:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package rhnlib needs python(abi) = 2.4, this is not available.
Package up2date needs python(abi) = 2.4, this is not available.

rpm --rebuilddb didn't work, nor did yum clean all.

I did a "yum remove rhnlib up2date" and that fixed the problem for me, too, allowing me to run "yum update".

Really getting sick of yum problems, though, and thinking of switching to a debian-based distro next time I reinstall.
 
Old 11-01-2007, 07:44 AM   #6
bds45701
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Thumbs up

I had similar issues with yum flagging rhnlib requiring python(abi) 2.4. The removal of the rhnlib using the command:

# yum remove rhnlib

also resulted in the removal of up2date and yum is now working and applying the system updates that were needed.....

Well, after some thought I am assuming the following to be true:

1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.

2. these programs are not needed in Fedora 7.

3. The upgrade process previously did not know that they were not needed so they were not removed until I manually did it.

4. One of my other fedora 7 systems was a clean install and it did not exhibit these issues.

5. This is not really a yum issue but an issue with the "fedora upgrade process" not being smart enough to clean up old un-needed programs.

Back working as desired. Thanks for the pointers!

Brian
 
Old 11-02-2007, 08:36 AM   #7
multitude
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by bds45701 View Post
1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.

2. these programs are not needed in Fedora 7.

Brian
Makes sense. The machine that I had problems with was also an upgraded Fedora version. It is now running quite happily without the removed packages. Thanks for figuring this one out!
 
Old 08-02-2008, 01:08 PM   #8
Annorax64
LQ Newbie
 
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
Add 4Suite to the list..

Quote:
Originally Posted by bds45701 View Post
I had similar issues with yum flagging rhnlib requiring python(abi) 2.4. The removal of the rhnlib using the command:

# yum remove rhnlib

also resulted in the removal of up2date and yum is now working and applying the system updates that were needed.....

Well, after some thought I am assuming the following to be true:

1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.


Brian
As of Fedora Core 9, you can add 4Suite as another package that needs to be erased (rpm -e 4Suite) before "yum update" will run properly the first time you run yum update on an upgraded Fedora Core 9 machine.

Annorax64
 
Old 09-06-2013, 09:26 AM   #9
Predatorian
Member
 
Registered: Mar 2008
Location: currently, where ever the army takes me
Distribution: Debian Lenny/Ubuntu or Arch Linux
Posts: 143

Rep: Reputation: 26
Would you guys also know if the rhnlib file is still required by later varients of RHEL 6? I'm connecting to a custom repo and I'm not sure if I really need it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Receiving constant error "Missing Dependency: /usr/bin/php is needed" GreenDragonComputers Linux - Software 3 05-09-2007 02:40 AM
PHP5 Upgrade Error: Missing Dependency: php = 4.3.x is needed by package php-pear vsystems Linux - Server 1 05-02-2007 08:17 AM
package error: ctr1.o missing? dgapp Ubuntu 1 12-21-2006 12:26 AM
Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword tmick Fedora 9 10-11-2005 01:06 PM
new package/dependency x-window system installer gui complete with files needed t3gah Linux - Games 4 02-14-2005 08:41 AM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration