LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib etc... (http://www.linuxquestions.org/questions/linux-software-2/error-missing-dependency-python-abi-%3D-2-4-is-needed-by-package-rhnlib-etc-560054/)

punt 06-07-2007 06:32 PM

Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib etc...
 
Okay, I was trying to update to Fedora 7 and got a bunch of errors.

I did the following a bunch of times:

Code:

# yum clean all
# yum update
# yum -y update
# rpm --rebuilddb

I still am getting the following:

Code:

--> Finished Dependency Resolution
Error: Missing Dependency: python(abi) = 2.4 is needed by package rhnlib
Error: Missing Dependency: python-optik is needed by package up2date
Error: Missing Dependency: python(abi) = 2.4 is needed by package up2date
Error: Missing Dependency: libedataserver-1.2.so.7 is needed by package pidgin

This occurs when doing yum update and yum -y update. What's going on and how do I fix it?

Thanks.

punt 06-07-2007 10:24 PM

Nobody knows? :(

I have had no success with searching for an answer.

Code:

# yum install python24-optik
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
fedora                    100% |=========================| 2.1 kB    00:00   
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

:(

punt 06-08-2007 08:02 AM

bump for desperate times :(

punt 06-08-2007 04:07 PM

Okay, I deleted up2date/rhnlib and removed pidgin and reinstalled. Things look better.

Glad I entertained you all. :p

multitude 10-31-2007 08:50 AM

same problem here
 
Quote:

Originally Posted by punt (Post 2780494)
Okay, I deleted up2date/rhnlib and removed pidgin and reinstalled. Things look better.

Glad I entertained you all. :p

I just had the same problem updating Fedora 7. Errors were:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package rhnlib needs python(abi) = 2.4, this is not available.
Package up2date needs python(abi) = 2.4, this is not available.

rpm --rebuilddb didn't work, nor did yum clean all.

I did a "yum remove rhnlib up2date" and that fixed the problem for me, too, allowing me to run "yum update".

Really getting sick of yum problems, though, and thinking of switching to a debian-based distro next time I reinstall. :(

bds45701 11-01-2007 06:44 AM

I had similar issues with yum flagging rhnlib requiring python(abi) 2.4. The removal of the rhnlib using the command:

# yum remove rhnlib

also resulted in the removal of up2date and yum is now working and applying the system updates that were needed.....

Well, after some thought I am assuming the following to be true:

1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.

2. these programs are not needed in Fedora 7.

3. The upgrade process previously did not know that they were not needed so they were not removed until I manually did it.

4. One of my other fedora 7 systems was a clean install and it did not exhibit these issues.

5. This is not really a yum issue but an issue with the "fedora upgrade process" not being smart enough to clean up old un-needed programs.

Back working as desired. Thanks for the pointers!

Brian

multitude 11-02-2007 07:36 AM

Quote:

Originally Posted by bds45701 (Post 2944344)
1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.

2. these programs are not needed in Fedora 7.

Brian

Makes sense. The machine that I had problems with was also an upgraded Fedora version. It is now running quite happily without the removed packages. Thanks for figuring this one out!

Annorax64 08-02-2008 12:08 PM

Add 4Suite to the list..
 
Quote:

Originally Posted by bds45701 (Post 2944344)
I had similar issues with yum flagging rhnlib requiring python(abi) 2.4. The removal of the rhnlib using the command:

# yum remove rhnlib

also resulted in the removal of up2date and yum is now working and applying the system updates that were needed.....

Well, after some thought I am assuming the following to be true:

1. rhnlib and up2date are leftovers from the previously upgraded fedora on the system.


Brian

As of Fedora Core 9, you can add 4Suite as another package that needs to be erased (rpm -e 4Suite) before "yum update" will run properly the first time you run yum update on an upgraded Fedora Core 9 machine.

Annorax64

Predatorian 09-06-2013 08:26 AM

Would you guys also know if the rhnlib file is still required by later varients of RHEL 6? I'm connecting to a custom repo and I'm not sure if I really need it?


All times are GMT -5. The time now is 09:24 PM.