LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-04-2007, 11:25 PM   #1
dissident_goodchild
Member
 
Registered: Feb 2007
Location: Spain
Distribution: OPENSUSE 10.3 64-BIT WITH GNOME
Posts: 229

Rep: Reputation: 30
enabled usb devices for virtualbox in opensuse 10.3


How can be enabled the USB devices for VirtualBox in openSUSE 10.3?

VboxManage list usbhost returns:

Code:
# VBoxManage list usbhost
VirtualBox Command Line Management Interface Version 1.5.2_OSE
(C) 2005-2007 innotek GmbH
All rights reserved.

[!] FAILED calling Host->GetUSBDevices(CollPtr.asOutParam()) at line 1866!
[!] Primary RC  = 0x80004001
[!] Full error info present: false, basic error info present: false
I tried also with usbusers group and full permissions without results...

Last edited by dissident_goodchild; 12-05-2007 at 09:08 AM.
 
Old 12-05-2007, 09:06 AM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
Which version of VirtualBox did you install? The OSE doesn't include usb support. That said, what kinds of devices are you trying to use? If it's a storage device first make sure it's not already mounted by the host. I did have a similar problem after upgrading Slackware from 11 to 12. libusb had taken over control of usb devices and VirtualBox depends on /proc/bus/usb. I had to edit the 50-udev.rules and comment the sections that identify my devices. Custom rules that name and symlink flash disks still work.
 
Old 12-05-2007, 09:10 AM   #3
dissident_goodchild
Member
 
Registered: Feb 2007
Location: Spain
Distribution: OPENSUSE 10.3 64-BIT WITH GNOME
Posts: 229

Original Poster
Rep: Reputation: 30
I have OSE version.

I need to mount an external hard disk.
 
Old 12-05-2007, 09:35 AM   #4
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
I just switched tabs back here an saw 1.5.2-OSE in the quoted error message. Doh! As I mentioned a few minutes ago the OSE doesn't include usb support. You'll have to replace it with the non-OSE version. It's still free and easy to install. It should work with the same VMs you've already set up.
 
Old 12-05-2007, 10:03 AM   #5
dissident_goodchild
Member
 
Registered: Feb 2007
Location: Spain
Distribution: OPENSUSE 10.3 64-BIT WITH GNOME
Posts: 229

Original Poster
Rep: Reputation: 30
Thank you. I will try it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot use any USB devices in VirtualBox davidguygc Linux - Hardware 7 06-14-2010 09:36 AM
LXer: Set Up VirtualBox On openSUSE 10.3. LXer Syndicated Linux News 0 11-16-2007 10:41 AM
Virtualbox setup on openSUSE 10.2 madgenius Suse/Novell 2 04-26-2007 11:36 PM
VirtualBox, Ubuntu 6.10 and Bad Devices ogee Linux - Software 2 03-02-2007 04:49 PM


All times are GMT -5. The time now is 06:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration