LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-25-2004, 03:42 AM   #1
harryman100
LQ Newbie
 
Registered: Nov 2003
Posts: 8

Rep: Reputation: 0
Difficult with Dependencies for the GIMP and uninstalling previous version of GLIB


Hi Everybody,

I was in the process of trying to install the GIMP 2.0, following its recent release. Naturally I met a dependancy, I needed GLIB >= 2.2.0, so I went off and downloaded the source for GLIB 2.4.0, on trying to install this, it turned out that my version of pkg-config was not good enough, so I went and got the source for the new version. did a ./configure && make && make install for pkg-config 0.15.0, which went fine, however, when I did pkg-config --version on the command line, it returned 0.12.0, so I went about trying to remove the previous version, I managed this, but then when I did pkg-config --version, on the command line, I now got an error. I solved this by moving pkg-config from /usr/local/bin/ to /usr/bin/ at last, when I now did pkg-config --version on the command line I got 0.15.0!!

However, I then went to do a ./configure && make && make install, in the GLIB directory, this worked fine. So I went back to the GIMP directory and did ./configure && make && make install, during the configure script, I now got a different message - "pkg-config --modversion GLIB returned 2.4.0 but version 2.0.6 was found!!!! if pkg-config was correct, you should try removing the old version"

This is where I hit problems, How do I remove the old version of GLIB? It was the one that was installed when I set the OS up, Am I doing something wrong, which means when I compile new software, it ends up in the wrong place (and can't be found, like pkg-config)? I am fairly computer literate, but linux is a bit of a new venture for me, and while I am happy on the command line, sometimes Linux lingo goes straight over my head!! I'm using Mandrake 9.0

Many Thanks in advance for any help you can offer me!!

Harry
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
Limewire removing previous version error novacrasher Linux - Software 0 02-01-2005 02:48 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
How to remove/reinstall OR revert X to a previous version? C38368 Linux - Newbie 1 05-26-2004 03:57 AM
how to revert back to the previous kernel version? prav_284 Red Hat 3 12-10-2003 04:51 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration