Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-24-2005, 06:05 AM   #1
LQ Newbie
Registered: Feb 2005
Location: Ukraine
Distribution: RH 9.0
Posts: 3

Rep: Reputation: 0
DBD-mysql 2.9004 and MakeMaker failure on RHEL


Have someone faced the problem with compilation DBD-mysql 2.9004 on RHEL ES release 3 (Taroon update 4) ? I upgraded mysql to 4.1.9 and now need to update DBD driver, however it seems to be a problem.

Exact problem is that I get a bunch of errors when do
"perl Makefile.PL", namely
"failed stat on a filename contained the newline in /usr/lib/perl5/5.8.0/ExtUtils/Liblist/ on line 97".
I researched and found that on that line searches for a library .so file, but I could not find a reason why this message comes up. is of version 1.29, perl 5.8.0 - stock RHEL distribution.

As the result, MakeMaker fails to write a valid Makefile, and I cannot compile the package.

As another option, I could install perl-DBD-mysql from .rpm, but RHEL does not have DBD-mysql of version 2.90xx, and other rpms from are incompatible by some parameters (perl version, glibc version etc). So I tried this also and failed too.

I'm open to any solution and suggestion. Please help.

Max Rudensky.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugzilla - MySQL - perl - DBD::mysql install problem Runningonair Linux - Software 8 10-12-2007 01:42 AM
DBD::MySQL + MySQL install problems. Elleroth Linux - Software 4 03-24-2006 07:53 AM
Error compiling perl-DBD-MySQL after upgrading to MySQL 4.1 pitaro920 Linux - Software 1 01-16-2006 05:28 PM
DBD-MySql-2.9004 Installation problem on Linux RedHat 9 luth Linux - Software 4 11-30-2004 05:56 AM
Can't install DBD::mysql or DBD::Pg DogTags Mandriva 2 01-21-2004 08:13 AM

All times are GMT -5. The time now is 05:13 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration