LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-16-2005, 03:49 PM   #1
ph4nt0m
LQ Newbie
 
Registered: Nov 2003
Location: UK
Posts: 15

Rep: Reputation: 0
Cisco vpnclient - kernel 2.6.10-1.760_FC3


Hi All
Like many other users of the Cisco vpnclient, I have had this program running successfully under older kernels. However I'm having problems with 2.6.10-1.760_FC3.

I have searched the Internet and attempted whatever has been suggested for my setup. I am using client version: vpnclient-linux-4.6.00.0045-k9.tar.gz. I followed the fixes in this thread (removing & on relevant lines and applying the patch) and all of the compilation errors were resolved apart from one.

The compilation error from vpn_install:

Code:
Making module
make -C /lib/modules/2.6.10-1.760_FC3/build SUBDIRS=/home/phantom/swdepot/vpnclient modules
make[1]: Entering directory `/lib/modules/2.6.10-1.760_FC3/build'
  CC [M]  /home/phantom/swdepot/vpnclient/interceptor.o
  LD [M]  /home/phantom/swdepot/vpnclient/cisco_ipsec.o
  Building modules, stage 2.
  MODPOST
Warning: could not find /home/phantom/swdepot/vpnclient/.libdriver.so.cmd for /home/phantom/swdepot/vpnclient/libdriver.so
Does anyone have any ideas on how to resolve this problem?

Many thanks.
 
Old 02-20-2005, 11:03 PM   #2
tvmaly
LQ Newbie
 
Registered: Feb 2005
Posts: 6

Rep: Reputation: 0
Did you find an answer?

Did you ever find a solution to your problem? I am having a similar problem on fedora core 3 running
2.6.10-1.766_FC3 kernel. I am not able to load the module. Here is the output in question from the vpn install

Warning: could not find /usr/src/vpnclient/.libdriver.so.cmd for /usr/src/vpnclient/libdriver.so
*** Warning: "put_user_size" [/usr/src/vpnclient/cisco_ipsec.ko] undefined!
*** Warning: "get_user_size" [/usr/src/vpnclient/cisco_ipsec.ko] undefined!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Cisco vpnclient and RHEL 4.0 exitsfunnel Linux - Networking 2 11-27-2005 06:26 PM
cisco vpnclient does not work with 2.6.3+ larley Linux - Software 0 08-14-2004 02:56 AM
cisco vpnclient - can't read profile karimd Linux - Networking 1 08-13-2004 04:05 PM
I'm looking for a script to keep cisco vpnclient up and running cccc Linux - Networking 0 09-16-2003 04:09 PM
Cisco VPNClient on Mandrake 9.0 a53man Linux - Networking 3 01-15-2003 03:25 AM


All times are GMT -5. The time now is 01:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration