LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-21-2003, 03:57 PM   #1
shnack
LQ Newbie
 
Registered: Apr 2003
Distribution: Redhat 9
Posts: 4

Rep: Reputation: 0
Can't get new Nvidia drivers to work


Well, I downloaded and installed Redhat 9 about three days ago. It installed and is working fine. I'm pretty new at Linux, so I would appreciate any help you could offer on the following problem I have.

I downloaded the new Nvidia drivers (NVIDIA-Linux-x86-1.0-4349.run). I installed the drivers just as the instructions said (sh NVIDIA-Linux-x86-1.0-4349.run). It downloaded a kernel interface and the install went fine. I then edited the XF86Config file, changing the "nv" to "nvidia" and made sure that dri and GLcore weren't in the "Load" section. When I restart X the screen just gets corrupt with low-res characters and I can't do anything, not even ctrl-alt-del. The only way to get X to load is to change the XF86Config to say nv again, but of course that's just the old built-in driver. Any suggestions?

Oh, and I have a PNY Geforce4 Ti 4800.
 
Old 04-21-2003, 05:30 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
get the nvchooser.sh script and make sure you have the right driver if you have not done it already

Last edited by DavidPhillips; 04-21-2003 at 05:48 PM.
 
Old 04-21-2003, 10:00 PM   #3
SenorPedo
Member
 
Registered: Oct 2002
Location: Richmond, VA
Distribution: RH7.3 & RH9
Posts: 40

Rep: Reputation: 15
Check your AGP settings...it seems that's a pretty likely candidate for those kinds of errors. If I recall correctly, you can set AGPGART or something like that in your XF86Config file to a value of 0 to disable it just to see if it works. If that solves the problem, then play with turning it back on at various settings till you find one that works. That might not be the right spelling for that option, but its discussed in the installation readme.
 
Old 04-22-2003, 01:05 AM   #4
shnack
LQ Newbie
 
Registered: Apr 2003
Distribution: Redhat 9
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the tip. I'll give it a try. I'm in the process of reinstalling Linux right now, so I'm in Windows downloading some drivers and things. I'll let you know how it turns out.

Oh, and I did run the nvchooser and tried to install the drivers from December, but the kernel driver wouldn't load properly. I'll try changing the config
 
Old 04-22-2003, 02:44 AM   #5
shnack
LQ Newbie
 
Registered: Apr 2003
Distribution: Redhat 9
Posts: 4

Original Poster
Rep: Reputation: 0
Well, I changed the NvAGP option to 0 in the XF86Config and now the driver works. Thank you! Now, is there any way to make it use AGP 2x or 4x instead of just disabling it?
 
Old 04-22-2003, 07:32 AM   #6
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
0 - disables AGP
1 - use NVAGP if possible
2 - use AGPGART if possible
3 - try AGPGART, then NVAGP

to reduce the APG rate ( if for example it defaults to 4x and its unstable)

in modules.config

alias char-major-195 nvidia
options nvidia NVreg_RegAGPRate=2 #force AGP rate to 2X

Not to RTFM you, but there is alot of good info there to help you tweak your card. You really should take a look.. For example, it lists supported agp chip sets which would help you better decide what options are best for your setup.
 
Old 04-22-2003, 07:36 AM   #7
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
sorry - typo above

should read modules.conf (/etc/modules.conf)

steve
 
Old 06-03-2003, 07:33 PM   #8
randallrayusa
LQ Newbie
 
Registered: Oct 2002
Location: Houston Texas
Distribution: Fedora Core
Posts: 24

Rep: Reputation: 15
NVchooser out of date.

The .run file isn't working ether! So look else where!!!!!! It says it can't find a driver and needs header to compile so out of luck on auto update!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Nvidia Drivers don't work... Roy-Svork Linux - Software 6 03-03-2008 03:46 AM
NVIDIA drivers won't work after reboot Marchsteiner Linux - Software 8 08-29-2005 03:01 PM
wget nvidia drivers - why doesn't it work?? r3dhatter Linux - Newbie 2 06-09-2005 01:19 AM
Nvidia drivers dont work. drgreenthumb Debian 12 08-15-2003 01:07 AM
Mdk9.1 - Nvidia drivers won't work fanatico Linux - Hardware 9 07-17-2003 10:53 PM


All times are GMT -5. The time now is 04:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration