LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-21-2005, 04:43 PM   #1
kotm22
LQ Newbie
 
Registered: Oct 2004
Location: South Wales
Distribution: Fedora
Posts: 4

Rep: Reputation: 0
Question Building Abiword from source


Hi, am trying to build Abiword from source (I need the Psion plugin) but I keep getting CONFIG_PATH errors for the fribidi dependency. I know that fribidi is present, and I know where the fribidi.pc file is, I just don't know how to point ./configure to the right place. Using FC3, newbie language please!
 
Old 03-21-2005, 04:48 PM   #2
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
http://www.abisource.com/download/

Is the PSION plugin not part of the abiword-plugins-tools...rpm?
 
Old 03-21-2005, 04:50 PM   #3
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
If you are talking about pkg-config then you need to set the PKG_CONFIG_PATH. Let's say your fribidi.pc was in /usr/local/lib/pkgconfig. You would run 'export PKG_CONFIG_PATH=/usr/local/lib/pkconfig' right before you run ./configure.
 
Old 03-21-2005, 05:02 PM   #4
kotm22
LQ Newbie
 
Registered: Oct 2004
Location: South Wales
Distribution: Fedora
Posts: 4

Original Poster
Rep: Reputation: 0
tried the export thing, but it still does not pick up either the fribidi.pc or enchant.pc files when I ./configure
 
Old 03-21-2005, 11:00 PM   #5
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Make sure you run the configure right after the export, don't run it in another shell/window. To check, run 'pkg-config --print-errors "fribidi >= 0.10.4" ' (assuming the abiword you have requires 0.10.4). If nothing comes up it is wroking properly. If it doesn't work, post the output (the last few lines from ./configure, what pkg-config does, etc).
 
Old 03-23-2005, 04:22 PM   #6
kotm22
LQ Newbie
 
Registered: Oct 2004
Location: South Wales
Distribution: Fedora
Posts: 4

Original Poster
Rep: Reputation: 0
Many thanks for your help, Abiword is now built and working. The plugins also built first time, but the psion one is not done by default. I ran config help and specified the psion build, this failed due to no psiconv being present on my system, now trying to build psiconv, unfortunately this does not want to build either, possibly because I am missing image magic. This is all very useful and I am learining lots about my system, but surely there must be an easier way?!?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building xine from source XaViaR Linux - Software 3 06-24-2005 09:38 AM
Building RPMs from source IronBeagle Linux - Software 2 03-04-2005 01:46 PM
building PHP 4.3.4-11 from source michaelbhahn Linux - Software 0 09-21-2004 05:55 PM
building from source Protex Slackware 2 02-24-2004 08:26 PM
Building Galeon from source abmhmd Slackware 2 05-22-2002 03:07 PM


All times are GMT -5. The time now is 10:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration