LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-20-2006, 09:59 PM   #1
Brian8568
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
Black screen and X cursor


I did a fresh install of FC 5 today. Everything was working great, so I did a yum update and downloaded 200+ new packages. I rebooted.

Now grub comes up, starts FC 5. udev starts, then the screen goes black, the mouse cursor becomes an X which still moves, and nothing happens. /var/logs has nothing obviously wrong.

So I ctrl-alt-bkspace. I get a login: prompt. I type root, and something flashes across the screen , then it blanks and returns with a login:

I tried to reinstall FC 5, but that changed nothing. I'm loathe to wipe it off again, but I need to get this thing done.

Brian
 
Old 07-20-2006, 10:32 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
When you get the login screen, do CTRL-ALT-F1 to get to a terminal, login as root and kill the xserver by doing "init 3". After that run "startx" and see if a gui starts. Post back any errors messages.
 
Old 07-20-2006, 11:24 PM   #3
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,245
Blog Entries: 15

Rep: Reputation: 233Reputation: 233Reputation: 233
hello. maybe you can check your log file /var/log/Xorg.0.log and check the final messages. much better if you can post it. ask reddaz.

i bet you have a video driver of X that's not compatible with your hardware. maybe somehow connected to the direct rendering manager. i've had this problem before.
 
Old 07-27-2006, 07:49 PM   #4
Brian8568
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for getting back so quick. I ended up having to reinstall from scratch due to some hardware issues, so it was probably all related.

Thanks anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black X cursor when gnome starts rosey Linux - Software 1 05-19-2006 08:03 AM
Black screen with cursor on boot mharley Linux - Newbie 3 02-19-2005 06:32 PM
MDK 9.2: X freezes with a black screen or blue screen with "X cursor" Apoc Linux - Newbie 10 03-30-2004 03:38 PM
MDK 9.2: X freezes on a black screen or blue screen with "X cursor" Apoc Linux - Software 1 12-29-2003 03:56 AM
KDE Little Black Cursor davecs Linux - Software 0 05-14-2003 04:49 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration