LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-24-2003, 08:12 PM   #1
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
apt-get through a proxy connection?


Hey all,

just wondering how in the world I can get apt-get to work through my internet connection, which runs through a proxy server to my windows machine...

Using pretty standard ports,

http: 8080
https 8081
ftp 8021
socks 1021

etc... I can also set up ports for pass-through, but how do I get apt-get to connect through that proxy server?

Thanks
-Shade
 
Old 06-25-2003, 06:33 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
bumpity... I'd love to be able to do this


-Shade
 
Old 06-29-2003, 09:15 PM   #3
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
Just one more bump to see if anyone has an answer....
 
Old 06-29-2003, 11:45 PM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Try setting the HTTP_PROXY enviro variable. You do this by typing: "export HTTP_PROXY=proxyserver.comort". Substitute FTP for the HTTP in the previous statement to do the same for the ftp proxies.
 
Old 06-29-2003, 11:48 PM   #5
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Sorry I jusr realised that a colon ( and a p make a smiley. So where you see the smiley above substitute in a colon followed by a p with no spaces.
 
Old 06-29-2003, 11:49 PM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
GODDAM SMILIES!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Old 07-01-2003, 08:23 PM   #7
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
Actually, that environment is already set, I can browse with lynx, etc.

I will see if wget works through it as well.

But apt-get is just not working...

-Shade
 
Old 07-01-2003, 08:44 PM   #8
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
Hot DAMN!

After a couple hours of searching obscure web pages through google, I came up with something from a very old post on another bbs.

Adding this line to apt.conf did it. I couldn't find this anywhere in the documentation or manpages. Maybe I missed it, but totally didn't see this.

Acquire::http::Proxy "http://proxy.server.here:8080/";

and that's all

-Shade
 
Old 09-13-2003, 11:21 AM   #9
vmicho
Member
 
Registered: Jun 2003
Location: Slovakia
Distribution: Debian unstable i586
Posts: 38

Rep: Reputation: 15
Lightbulb I got it

It seems for me apt-get is ignoring apt.conf configuration.
Even if I specify the proxy servers in apt.conf, nothing happens.

Must set env. vars :
$ export ftp_proxy=http://192.168.1.1:80/
$ export http_proxy=http://192.168.1.1:80/
$ apt-get update
...

Bad thing :
$ export http_proxy=192.168.1.1:80/
$ apt-get update
will result in:
> 0% [Connecting to 80]
and some error message

Note : Internet connection in our university residence is weird. No gateway, no DNS, just proxy.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set up proxy in Apt-Get's apt.conf? rykel Fedora 9 10-09-2013 03:24 AM
apt via digest proxy HSukirman Linux - Newbie 1 06-26-2005 09:30 PM
apt-proxy and cron-apt - download once for the whole LAN Abject Debian 1 06-20-2004 01:53 PM
APT behind a proxy geniarse Debian 4 04-14-2004 09:26 PM
proxy settings for apt? h/w Linux - Software 0 09-26-2003 09:51 AM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration