LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-13-2004, 04:48 PM   #1
hewsonism
LQ Newbie
 
Registered: Dec 2003
Location: San Jose, CA
Distribution: Fedora
Posts: 10

Rep: Reputation: 0
apache displays .cgi file instead of executing it


hey.

as the subject says when i go to execute a cgi script via a webbrowser
apache instead displays the file instead of executing it.
permisions are set at 755 and owner/group are apache/apache
the #! line has the propper path.

this is essentially my first stab at apache so any help would
be greatly apreciated....

hewsonism
 
Old 01-13-2004, 05:44 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Have you configured your httpd.conf file correctly? Any way you can post it here or link to it, well mainly the portions that pertain to cgi in it?
 
Old 01-13-2004, 09:12 PM   #3
nightwulf
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
As trickykid stated, this sounds like a misconfiguration in httpd.conf. At the very least, you're probably missing a line similar to:

AddHandler cgi-script .cgi

in your httpd.conf. Open the file up with a text editor and work your way through; it's very well-documented.

Regards,
nightwulf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CGI Scripts not executing, pls help john_d13 Linux - General 3 12-22-2004 02:05 PM
CGI File Not Executing on Apache Server kaplan71 Linux - Software 2 10-21-2004 07:12 AM
Executing from cgi theonebeyond Programming 4 10-04-2004 11:30 PM
Apache: png file in CGI directory doza Linux - Software 2 08-27-2004 08:05 AM
Probs running .jar file via CGI script under Apache blimbo Programming 1 07-22-2004 10:29 AM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration