LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-03-2003, 10:23 PM   #1
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Rep: Reputation: 30
Annoying clock problem! (using mandrake 9.1)


For some reason every time I restart my computer my clock sets itself 4 hours back. It keeps doing so with each restart, which is quite annoying. If someone can help me fix this problem, I would greatly appreciate it. Thank you for your time.
-calimer
 
Old 08-03-2003, 10:35 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
what is the time in your bios?
 
Old 08-03-2003, 10:47 PM   #3
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Original Poster
Rep: Reputation: 30
Not sure, how do I check that? Oh by the way, I have a program (emulated TimeSync) which adjusts my time, but I can only use that when I'm online (I have dialup) and having to use it all the time is annoying. I tried to fix things by using $hwclock hctosc or whatever the command is to set the hardware clock to the software clock, but it didn't fix things
-calimer
PS I have a compaq presario 5150, I don't think looking in the bios for stuff is as easy as with other comps.
PPS my windows clock doesn't seem to have any problem, the time is always fine in it
 
Old 08-03-2003, 10:55 PM   #4
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
On the Windoze side your clock gives you the correct time, yes?
The local time?

On the Linux side, use your time configuration program for Mandrake
and make sure that you have not set the local time to be the same
as GMT/UTC.

On RedHat, you need to have in /etc/sysconfig/clock

UTC="false"

As you are using Mandrake, your configuration file maybe in a different
location and possibly different format.
 
Old 08-03-2003, 11:13 PM   #5
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Original Poster
Rep: Reputation: 30
I have two clock files, one in /sbin and one where Drozz pointed. Both look exactly the same and have UTC false, although not in quotes. Here is how it reads.

UTC=false
ARC=false
ZONE=America/New_York

Hmm. Thank you for replies.
-calimer
 
Old 08-03-2003, 11:21 PM   #6
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
I do not know aynthing about your emulsync program, but could it be
that it thinks your BIOS clock is set to UTC?

After all EDST = UTC - 4 h

so somebody thinks your BIOS clock is set to UTC, then
subtracts 4h to set your sytem clock to EDST.
 
Old 08-03-2003, 11:30 PM   #7
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Original Poster
Rep: Reputation: 30
What exactly is an emulsync program? Something is definitely subtracting 4 from the "base" time that my clock is set at when I start up the computer. I hope I made sense by what I meant when 4 is subtracted each time I restart the comp. So if it's set at 10pm now and I restart, the time when I load up will be 6pm. If I restart again then the clock is set to 4pm. Others must have problems like this on mandrake, especially since I had this problem with my first install on mandrake 9.1. The second time I only used timesync to correct my clock. Then timesysc stopped working for some reason (I think it might actually of been something related to the clock) and so I manually fixed the time using "adjust date and time" and clock hell once again emerged. Hopefully I can get this fixed soon. Thank you all for your help.
-calimer
 
Old 08-03-2003, 11:44 PM   #8
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
"I have a program (emulated TimeSync)"

Sorry, when I typed emulsync I meant the above.

And you have restated what I said above.

You have you BIOS clock set to 20:00h

When you boot up, your something in your system is saying

"Ah, the BIOS says the time is 20:00h,
but that is set to UTC,
and the time zone on this machine is EDST,
so since

EDST = UTC - 4h

I must set the sytem clock to 20:00h - 4 h, namely 16:00h"

So the root of the problem is why your system thinks the BIOS
is set to UTC.

When you fire up drax, does that have a time configuration option?
(I do not know drax, since I do not have a Mandrake system.)

Otherwise use the appropriate Mandrake time configuration program
and check that "BIOS IS UTC" is not checked.

And to repeat my implied question, at which point does the
emulated TimeSync program, whatever that is, first get executed?
Perhaps to enlighten me, you could tell me from where you got this program.

This should be a simple problem to solve, with the symptoms arising from
your time zone EDST = UTC - 4h being so evident.
 
Old 08-04-2003, 02:01 AM   #9
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Original Poster
Rep: Reputation: 30
TimeSync is a program that I run with wine once i have linux booted up. It is a program that I used to use on windows since my clock sometimes likes to run a little fast. I don't think drax has a configuration for the clock but I'll try to find what I can. Maybe KDE has one somewhere. Thank you for your help, I really appreciate it.
-calimer
 
Old 08-04-2003, 04:35 AM   #10
calimer
Member
 
Registered: Apr 2002
Distribution: Mandrake 10.1
Posts: 181

Original Poster
Rep: Reputation: 30
Well, I found a small date program in drax. It doesn't let me do anything except set the date, time, and timezone. When I select the timezone it asks me "is your hardware clock in GMT?" or something like that. I selected yes, although I have no idea what that means. If selecting no is the way to go then let me know. Thank you for your time.
-calimer
 
Old 08-04-2003, 08:50 AM   #11
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
Quote:
"is your hardware clock in GMT?" or something like that. I selected yes,
No, no, no! :+)

Sorry.

GMT to all everyday usage is the same as UTC.

UTC is Universal Coordinated Time
GMT is Greenwich Mean Time

If you want to see the precise difference, go to

http://www.ntp.org/ntpfaq/NTP-s-time.htm#AEN963

So you ARE telling your system by doing this that you BIOS time is UTC,
hence the system will substract 4h during the boot up clock setting.

So go back, and set it to

Bios is GMT "NO"

To keep your clock right, you should be using the standard package
ntp. I have just battled with the configuration file for this, and now have my gateway machine synced with an external site, and the other pc on my
home LAN, synced to that machine, and it is working well.

Thus if you want any help in setting ntp up, I have first hand experience.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.2 Download Collection no longer working - annoying me! Alexanda G Mandriva 0 06-12-2004 10:49 PM
Network fails fo work in Mandrake 10.0; annoying reboot required chrisrl Linux - Networking 2 03-27-2004 06:44 PM
Hacking Gnome/Mandrake (Annoying ''start'' menu) Baldorg Linux - Software 0 11-16-2003 12:06 PM
small but annoying problem in mandrake 9.1 with KDE calimer Linux - Software 1 05-25-2003 10:41 PM
Mandrake time clock descentx13 Linux - General 2 05-27-2002 08:42 PM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration