LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-04-2008, 09:24 PM   #1
ioibird
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Rep: Reputation: 0
An error about "Fix it to use EXTRA_CFLAGS"


Hi,

When I can't compile my Attansic network card, because of this error:

CFLAGS was changed in "home/test/Attansic/src/Makefile". Fix it to use EXTRA_CFLAGS. Stop.

the kernel is kernel 2.6.24.

Any help is appreciated

thanks a lot
 
Old 03-05-2008, 02:02 PM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
Quote:
Originally Posted by ioibird View Post
Hi,

When I can't compile my Attansic network card, because of this error:

CFLAGS was changed in "home/test/Attansic/src/Makefile". Fix it to use EXTRA_CFLAGS. Stop.

the kernel is kernel 2.6.24.

Any help is appreciated

thanks a lot
Try setting the variable
KBUILD_NOPEDANTIC
to 1 before running make
 
1 members found this post helpful.
Old 08-14-2008, 07:34 PM   #3
danix803
LQ Newbie
 
Registered: Aug 2008
Location: South Carolina
Distribution: Mepis
Posts: 7

Rep: Reputation: 0
Question Where???

Quote:
Originally Posted by Uncle_Theodore View Post
Try setting the variable
KBUILD_NOPEDANTIC
to 1 before running make
Where is that located at???
In what file???
What is the path to the file where I will need to change that???
The kernel is 2.6.26 (Flavor = Mepis)
Thanks in advance...

Love is very patient and kind, never jealous or envious, never boastful or proud, never haughty or selfish or rude. Love does not demand its own way. 1 Corinthians 13:4 - 8, 13 The greatest ........ is LOVE.
"A firsthand account of discrimination (racial, sex, orientation, disability) in Federal Civil Service: Glass Ceilings" - Buy my book: http://www.authorhouse.com/BookStore...kid~50452.aspx

Last edited by danix803; 08-14-2008 at 07:45 PM. Reason: add signature
 
Old 08-16-2008, 06:23 PM   #4
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
You don't need to set it in a file. Just, instead of running

make

in a terminal, type

KBUILD_NOPEDANTIC=1 make

Or, type

export KBUILD_NOPEDANTIC=1
make
 
Old 08-16-2008, 07:59 PM   #5
danix803
LQ Newbie
 
Registered: Aug 2008
Location: South Carolina
Distribution: Mepis
Posts: 7

Rep: Reputation: 0
Question That didn't work for me

I tried that... and here's what I got...

I ran... KBUILD_NOPEDANTIC=1 make ... in a console...

root@somecomputer:/# KBUILD_NOPEDANTIC=1 make
make: *** No targets specified and no makefile found. Stop.

What file is that setting found in???
I would appreciate any help that you can offer with this...

Last edited by danix803; 08-16-2008 at 08:31 PM. Reason: Found more data...
 
Old 08-16-2008, 08:09 PM   #6
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
Quote:
Originally Posted by danix803 View Post
I tried that... and here's what I got...

I ran... KBUILD_NOPEDANTIC=1 make ... in a console...

root@somecomputer:/# KBUILD_NOPEDANTIC=1 make
make: *** No targets specified and no makefile found. Stop.


I would appreciate any help that you can offer with this...
You need to run make from the directory that contains the Makefile for your module or application. Usually, it's located in the top-level directory of the source tree. So, you should cd to /home/test/Attansic/src/ or something like that and run it from there.
 
Old 08-16-2008, 09:35 PM   #7
danix803
LQ Newbie
 
Registered: Aug 2008
Location: South Carolina
Distribution: Mepis
Posts: 7

Rep: Reputation: 0
Lightbulb Thanks...

Quote:
Originally Posted by Uncle_Theodore View Post
You need to run make from the directory that contains the Makefile for your module or application. Usually, it's located in the top-level directory of the source tree. So, you should cd to /home/test/Attansic/src/ or something like that and run it from there.
Okay... I'll do make for each and everyone of them... thanks...

I tried... but they are still failing... here's what they say when I try to run ./configure and/or make them...
Alsa
/usr/bin/make -C /usr/src/linux-headers-2.6.26 SUBDIRS=/usr/src/modules/alsa-driver O=/usr/src/linux-headers-2.6.26 CPP="gcc-4.1 -E" CC="gcc-4.1" modules
make[3]: Entering directory `/usr/src/linux-headers-2.6.26'
/usr/src/linux-headers-2.6.26/arch/x86/Makefile:41: /usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu: No such file or directory
and cdfs
make -C /usr/src/linux-headers-2.6.26 SUBDIRS=/usr/src/modules/cdfs/2.6 modules
make[3]: Entering directory `/usr/src/linux-headers-2.6.26'
/usr/src/linux-headers-2.6.26/arch/x86/Makefile:41: /usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu: No such file or directory
make[3]: *** No rule to make target `/usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu'. Stop.
and OV511
Building OVCam drivers for 2.6 kernel.
/usr/bin/make -C /usr/src/linux-headers-2.6.26 SUBDIRS=/usr/src/modules/ov511 modules
make[3]: Entering directory `/usr/src/linux-headers-2.6.26'
/usr/src/linux-headers-2.6.26/arch/x86/Makefile:41: /usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu: No such file or directory
make[3]: *** No rule to make target `/usr/src/linux-headers-2.6.26/arch/x86/Makefile_32.cpu'. Stop.

Last edited by danix803; 08-17-2008 at 02:05 PM. Reason: Found more data
 
Old 11-15-2008, 09:47 PM   #8
ICE_BM
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Rep: Reputation: 0
not quite enough info for a newbie...

Hi all,
Someone else might end up in this thread because the problem is quite common. The first answer given was the right info, but just missed one crucial thing that a newbie would not perhaps pick up on.

I had the exact same problem, and managed to work it out, so here is the full solution:

Asus P5Q motherboard, needs atl1e driver for Attansic/Atheros LAN, kernel 2.6.24 fc8.

The easist answer is to upgrade the kernel to 2.2.26, but without a LAN that might be tricky. In my case I'm using a packaged distro (mythdora5), and want to keep that as standard as possible, so need the harder approach.
Please note that this solution does not build a custom kernel, it simply builds the required kernel module (driver file) against the installed kernel. The info says that it's good for 2.6.24 and 2.6.26
If not done already get the driver here (on some other working internet machine):

http://dlsvr04.asus.com/pub/ASUS/mb/...nuxDrivers.zip

This archive has both sound and LAN drivers, use winrar to open it (see why in a minute), navigate to "L1e_LAN", and open the winrar archive (that's why), extract the files to a USB stick.

insert the usb stick into the fc8 box. Now, on mythdora5 it automounts for me, but this may not happen in your fc8, you're on your own there sorry. Once you get the USB stick mounted in fc8, copy the files into the suggested directory

/usr/local/src/atl1e

Check that you have in that location at least the file

atl1e.7

and a dir called

src
(then as root, don't type the #, that's the root prompt...)
#cd /usr/local/src/atl1e
#KBUILD_NOPEDANTIC=1 make install

the result will be a driver file called atl1e.ko loaded into

/lib/modules/<KVER>/kernel/drivers/net/atl1e

where <KVER> is your kernel version. Check this with:

#find / -name atl1e.ko

Two locations should show up, one in /lib/modules and one where the driver was built.

The driver file will be automatically 'probed' by the system, the build process will automatically install

alias eth0 atl1e

into the system setup file /etc/modprobe.conf
(note there's no action required by you here, but this explains how it works....)

Now reboot
#init 6

And then enjoy my friends...

Last edited by ICE_BM; 11-16-2008 at 01:22 AM.
 
Old 10-14-2009, 05:06 AM   #9
ICE_BM
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Rep: Reputation: 0
Found myself back here again...

Funny how life works, I found my way back to my own post, with the same problem, this time I've got FC10 on the same P5Q motherboard, and for some strange reason the NIC does not start up on boot. The interface can be brought up from a terminal once the machine is up, and seems to work ok:

ifup eth0

FC10 is a bit different than FC8, for example modules.conf has been replaced by /etc/modprobe.d/modprobe.conf.dist and has lots of stuff in it. I tried doing the work above to install manually, but still no good. The atl1e module is actually loaded (lsmod), but dmesg has no record of starting the NIC until ifup is run manually once the machine is running.

The driver file reports version 1.0.0.7 using
ethtool -i eth0

yum update and new kernel etc still don't fix this problem, so I have taken the very lazy approach of putting a line in my rc.local file:

/sbin/ifup eth0

dmesg shows a weird thing (weird to me anyway)
---
ATL1E 0000:02:00.0: ATL1E: eth0 NIC Link is Up<100 Mbps Full Duplex>
ADDRCONF(NETDEV_UP): eth0: link is not ready
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
---

Is this link not ready the reason why it won't come up when the machine starts?

Just a further note here, I have seen comments that FC11 has a bad/broken driver for this NIC, not sure on the current status of that.

I see there is v1.0.1.0 of the driver source available, but I have no source on my mythdora10.21 (packaged distro again), so can't be bothered getting all that on board to try it.

Pleased to hear if anyone knows the 'proper' way to fix this (my method above is only a 'hack' the way I see it...)
 
  


Reply

Tags
atheros, attansic, cflags, fc10, fc8, lan, mythdora, nic, reboot, startup


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FIX: wine error "No Program Start Menu Found" JackSmith Linux - Games 3 07-02-2009 11:38 PM
chmod: 1: Syntax error: "(" unexpected - what's this mean and how do I fix it? SeriesOne Linux - Newbie 6 02-22-2008 02:18 PM
[SOLVED] How can I fix "Error: BadWindow (invalid window parameter)" ShellyCat Linux - Desktop 1 08-17-2007 10:42 AM
KDE Error "Conversation with su failed" SuSE 10.2 Fix jdmcdaniel3 Suse/Novell 4 05-24-2007 07:20 AM
How do I fix a "Grub read error"?? Tiyogi Linux - Newbie 1 06-02-2004 09:55 AM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration