LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-12-2005, 11:42 AM   #1
subaruwrx
Member
 
Registered: Mar 2004
Distribution: Ubuntu Feisty
Posts: 641

Rep: Reputation: 30
alsamixer invalid argument


Code:
revenant@debian:~/rp-pppoe-3.5$ sudo alsamixer

alsamixer: function snd_ctl_open failed for default: Invalid argument
revenant@debian:~/rp-pppoe-3.5$ su
Code:
debian:/home/revenant/rp-pppoe-3.5# modinfo soundcore
filename:       /lib/modules/2.6.8-10-amd64-k8/kernel/sound/soundcore.ko
alias:          char-major-14-*
license:        GPL
author:         Alan Cox
description:    Core sound module
depends:
vermagic:       2.6.8-10-amd64-k8 gcc-3.4
debian:/home/revenant/rp-pppoe-3.5#
Code:
debian:/home/revenant/rp-pppoe-3.5# lspci|grep audio
0000:00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
Code:
debian:/home/revenant/rp-pppoe-3.5# lsmod|grep snd
snd_emu10k1            90088  0
snd_rawmidi            26532  1 snd_emu10k1
snd_pcm_oss            56680  0
snd_mixer_oss          19520  1 snd_pcm_oss
snd_pcm               100876  2 snd_emu10k1,snd_pcm_oss
snd_timer              24904  1 snd_pcm
snd_seq_device          9164  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         73220  1 snd_emu10k1
snd_page_alloc         12944  2 snd_emu10k1,snd_pcm
snd_util_mem            5440  1 snd_emu10k1
snd_hwdep              10440  1 snd_emu10k1
snd                    56936  10 snd_emu10k1,snd_rawmidi,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore              11232  1 snd
debian:/home/revenant/rp-pppoe-3.5#
Any idea why?
 
Old 03-12-2005, 02:34 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
do you have something strange in your ~/.asoundrc ? (i think using sudo that's user home not root home ?)
or have you altered the alsa.conf thingy ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accept(): Invalid Argument bonhomme Programming 6 07-14-2012 11:12 PM
KDSKBENT: Invalid Argument tommytomato Linux - Newbie 6 08-27-2004 11:23 PM
[ Invalid Argument on 'iptables' ] benleung Linux - Security 1 09-23-2003 01:25 AM
xawtv - invalid argument liguorir Linux - Software 0 06-17-2003 09:55 PM
invalid numeric argument Copenhagen Cowboy Linux - General 4 03-29-2001 03:01 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration