LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-14-2012, 06:00 AM   #1
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Rep: Reputation: 0
/usr/local/libexec/dovecot/dovecot-lda - IS MISSING ?!?


I'm trying to trouble shoot (on a CentOS6.3 server I'm building) the postfix service, which uses the Dovecot LDA. However, I'm getting the following entries in my /var/log/maillog:
Code:
Aug 14 16:58:03 bk1 pipe[23213]: fatal: pipe_command: execvp
/usr/local/libexec/dovecot/dovecot-lda: No such file or directory
Aug 14 16:58:03 bk1 postfix/pipe[23212]: 587F92197D: to=<peter@mydomain.com>,
relay=dovecot, delay=803, delays=803/0.01/0/0.03, dsn=4.3.0, status=deferred
(temporary failure. Command output: pipe: fatal: pipe_command: execvp
/usr/local/libexec/dovecot/dovecot-lda: No such file or directory )
Aug 14 16:58:07 bk1 dovecot: imap: Server shutting down. bytes=1075/3421
When I tried to check the permissions on /usr/local/libexec/dovecot/dovecot-lda, I found that the path only goes as far as /usr/local/libexec/.

Can anyone tell me what I'm missing and how I might get it? Extra points for telling me why I don't have it already!

Many thanks guys.

Peter

Last edited by snowweb; 08-14-2012 at 08:06 AM.
 
Old 08-14-2012, 08:05 AM   #2
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Further investigation shows me that the path is used in the /etc/postfix/master.cf
Code:
dovecot   unix  -       n       n       -       -       pipe
  flags=DRhu user=vuser:vusers argv=/usr/local/libexec/dovecot/dovecot-lda -f ${sender} -d ${recipient}
That line is there to make Postfix communicate with Dovecot, for the purpose of authenticating users and locating users Maildirs (as far as I understand it) and it comes direct from the dovecot documentation here.

I've searched Google for the error in my log file (/usr/local/libexec/dovecot/dovecot-lda: No such file or directory) but it returns absolutely nothing when inside quotes. It's hard to believe out of all the log files excepts posted online, that not one of them has been indexed containing that line! It's very curious.
Meanwhile, I have no idea how or where to get the missing components? Please can someone check their installation and tell me what should be there?

Thanks,

Peter
 
  


Reply

Tags
dovecot, postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS printing error: ="/usr/local/libexec/cups/filter/rastertosamsungspl failed ted_chou12 Linux - Software 0 08-04-2012 06:22 AM
postfix+dovecot in rhel6.1 not getting local mails JATA01 Linux - Server 8 07-15-2012 01:23 AM
dovecot-lda/postfix permission issues deathclaw Linux - Server 3 06-22-2012 12:56 PM
postfix used dovecot lda problem xiutuo Linux - Server 1 11-12-2009 08:58 PM
Dovecot: Missing POP3 70mas Linux - Software 1 07-08-2007 11:23 AM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration